summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-07-19 16:45:03 +1200
committerKent Fredric <kentnl@gentoo.org>2016-07-19 16:45:03 +1200
commit154cfea7d79f54499f4fad82441548a0ff7e9a27 (patch)
tree1ba21c764334bbda9a97ffc0b67c6a37de8ad816 /dev-perl
parentdev-perl/CDB_File: Bump to version 0.990.0 (diff)
downloadgentoo-154cfea7d79f54499f4fad82441548a0ff7e9a27.tar.gz
gentoo-154cfea7d79f54499f4fad82441548a0ff7e9a27.tar.bz2
gentoo-154cfea7d79f54499f4fad82441548a0ff7e9a27.zip
dev-perl/CGI: Bump to version 4.310.0
- Add USE="examples" - Remove author tests - Update metadata.xml remote-id's Upstream: - HTML attributes now sorted by default - warnings fixed in test harness and STORE sub - taint addedf to file_upload example - %QUERY_PARAM now cleaned/unset under mod_perl - Cookie handling now supports SameSite - MultipartBuffer renamed to CGI::MultipartBuffer Keywording: ~amd64-fbsd: Dropped, not supported by dependency dev-perl/Test-Deep ~m68k: Dropped, not supported by dependency dev-perl/Test-Warn Package-Manager: portage-2.3.0 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/CGI/CGI-4.310.0.ebuild41
-rw-r--r--dev-perl/CGI/Manifest1
-rw-r--r--dev-perl/CGI/metadata.xml8
3 files changed, 45 insertions, 5 deletions
diff --git a/dev-perl/CGI/CGI-4.310.0.ebuild b/dev-perl/CGI/CGI-4.310.0.ebuild
new file mode 100644
index 000000000000..bc7909e533b8
--- /dev/null
+++ b/dev-perl/CGI/CGI-4.310.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=LEEJO
+DIST_VERSION=4.31
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Simple Common Gateway Interface Class"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ >=virtual/perl-File-Spec-0.820.0
+ >=virtual/perl-File-Temp-0.170.0
+ >=dev-perl/HTML-Parser-3.690.0
+ virtual/perl-if
+ >=virtual/perl-parent-0.225.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.980.0
+ >=dev-perl/Test-Deep-0.110.0
+ >=dev-perl/Test-Warn-0.300.0
+ )
+"
+
+src_test() {
+ perl_rm_files t/compiles_pod.t t/changes.t
+ perl-module_src_test
+}
diff --git a/dev-perl/CGI/Manifest b/dev-perl/CGI/Manifest
index 6f5c664a9e61..f73d7c3da9fb 100644
--- a/dev-perl/CGI/Manifest
+++ b/dev-perl/CGI/Manifest
@@ -1,2 +1,3 @@
DIST CGI-4.22.tar.gz 194314 SHA256 8cd695f032b630fc4b5cf6c0a39912ff30cae0f7da03d01965ca2ac28b4dcca8 SHA512 becd37e56ca3fe8a6ab6069d99ddc65838d4aa00b57b6e30a5e2bcf73e84dff9a3f5f2841549f6627fe29d46607254197f3a03f308dc5fb6add3ece60719871d WHIRLPOOL 003483d2852493ad2b4be0bbd018e590d264592dcd3e37da6adfaa004c3818c9c4cbf631635ede5b3cf0150429f7b4ce0e8ce647969ed6fff66fc905e918c849
DIST CGI-4.25.tar.gz 194815 SHA256 efb3e5235ada6a91f97ca2905399a686bedea60f6b525e52f4a147baff4f131a SHA512 2f9befda944867d751a100024732de71073a47c2e63fdbbf86291422258da47adfe9677b7c39451958cf6e936a015c1b9c7f8338563f2548b7446128f9cb6b8b WHIRLPOOL 295a7fe94d6d7b4a6c01ce3aa41b356bb278ae9004c278b75c512094db5919860bf2d089f884d9bc77d9be4aea728f3fb964fa1f0cba45702b6a1dee1d6b153c
+DIST CGI-4.31.tar.gz 197018 SHA256 dee34f45525efb698d02c56ba2458a72acc34c4dcb05344706b587840b4e8c99 SHA512 a3fc6a88bed4b86f5763c07ec0961d2b06754e0a2bc9112e87b12025975618d97f626895c7d8b3a2f85a2ba5adcf99a132801a52d54652cd09ae3f053457c411 WHIRLPOOL 361b18445a25adb6f03e4114f788a097c82811f228355fb7c0634e9a8a1d340c9d9e5f2a656a51216c57057f768c7fb5a865bbb30ba6c2ce9fc8c17e83b5223c
diff --git a/dev-perl/CGI/metadata.xml b/dev-perl/CGI/metadata.xml
index e8016bb70c86..c4d3366909a9 100644
--- a/dev-perl/CGI/metadata.xml
+++ b/dev-perl/CGI/metadata.xml
@@ -8,16 +8,14 @@
<upstream>
<remote-id type="cpan">CGI</remote-id>
<remote-id type="cpan-module">CGI</remote-id>
- <remote-id type="cpan-module">CGI::Apache</remote-id>
<remote-id type="cpan-module">CGI::Carp</remote-id>
<remote-id type="cpan-module">CGI::Cookie</remote-id>
- <remote-id type="cpan-module">CGI::Fast</remote-id>
+ <remote-id type="cpan-module">CGI::File::Temp</remote-id>
+ <remote-id type="cpan-module">CGI::HTML::Functions</remote-id>
+ <remote-id type="cpan-module">CGI::MultipartBuffer</remote-id>
<remote-id type="cpan-module">CGI::Pretty</remote-id>
<remote-id type="cpan-module">CGI::Push</remote-id>
- <remote-id type="cpan-module">CGI::Switch</remote-id>
<remote-id type="cpan-module">CGI::Util</remote-id>
- <remote-id type="cpan-module">CGITempFile</remote-id>
<remote-id type="cpan-module">Fh</remote-id>
- <remote-id type="cpan-module">MultipartBuffer</remote-id>
</upstream>
</pkgmetadata>