summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-30 23:46:19 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-30 23:46:32 +0200
commit1f04809ced1d62788179b0ac5887e83694348295 (patch)
tree39377b3f2aacc3414cc2e4fb62c28d5f40ab0c26 /dev-perl
parentsys-firmware/seabios: use tool-prefixed strip and cpp (diff)
downloadgentoo-1f04809ced1d62788179b0ac5887e83694348295.tar.gz
gentoo-1f04809ced1d62788179b0ac5887e83694348295.tar.bz2
gentoo-1f04809ced1d62788179b0ac5887e83694348295.zip
dev-perl/Convert-Binary-C: Version bump 0.84
Closes: https://bugs.gentoo.org/730084 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Convert-Binary-C/Convert-Binary-C-0.840.0.ebuild32
-rw-r--r--dev-perl/Convert-Binary-C/Manifest1
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Convert-Binary-C/Convert-Binary-C-0.840.0.ebuild b/dev-perl/Convert-Binary-C/Convert-Binary-C-0.840.0.ebuild
new file mode 100644
index 000000000000..ee8cb2a2a81d
--- /dev/null
+++ b/dev-perl/Convert-Binary-C/Convert-Binary-C-0.840.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MHX
+DIST_VERSION=0.84
+# NB: Examples are generated
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Binary Data Conversion using C Types"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="|| ( GPL-1+ Artistic ) BSD"
+
+# bison >= 1.31?
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+PERL_RM_FILES=(
+ tests/802_pod.t
+ tests/803_pod_coverage.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ # Parallel CC breaks
+ "-j1"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Convert-Binary-C/Manifest b/dev-perl/Convert-Binary-C/Manifest
index 243f7550400f..09e2c3568e82 100644
--- a/dev-perl/Convert-Binary-C/Manifest
+++ b/dev-perl/Convert-Binary-C/Manifest
@@ -1,2 +1,3 @@
DIST Convert-Binary-C-0.78.tar.gz 1564698 BLAKE2B 220f6221769a9907d9dcadd6ba6ffcd04114cdc8d03d4a63a43f95a492b7fa45fa97451c4dbda64bb54e9053914f0ab75821f9d6b84ae6e8b266c9cf89c9be41 SHA512 d9b85ce2ae870c2de6c2fa0838a6b20000ec8d33f19a989f8ebe1b026f2796ae7e924391a0fe387310a3217c75dcd797ea819ff964a9c3e448d007c16d41040c
DIST Convert-Binary-C-0.79.tar.gz 1559047 BLAKE2B 71e509742abc71a444082b524485d4116b92e827979033bae21d2fc8cc68e8f0e9e556d33bc3cdd6ca5f219fe665cd2a706c4a439cb11fe1f160d8c1af3afd31 SHA512 2771d54136ed433b33b729c71a2d1ed30a6601ce63c8f40b0b580db34557fd2cedf7262d7ee990bd8f5ce33800588fc3532d806335a21ac51738a8a222059b02
+DIST Convert-Binary-C-0.84.tar.gz 1348549 BLAKE2B 7271f68d26cd387aa75c2eb966bd8497081e690ed7bd1339c98864fe9349398c723dab26120ecdaf534f28a969e85df95aa9ff7bbde8e4f1146a4a9b79818f1e SHA512 1c5160b39e5b64dc61c5e6bfeb163728352721ebfdc8c5096557e19293136e0aea613bf166e9b539a3980c39bc98466c99691be7d4f7325dac0c05fdd324440d