summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 14:48:03 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 14:48:03 +1200
commit34a5885d1e885fc2ed46a97021d4916bf9495618 (patch)
tree3caeb09cd6b12e94c2a74d77a125b205668606d9 /dev-perl
parentdev-perl/Mojolicious: Bump to version 8.500.0 (diff)
downloadgentoo-34a5885d1e885fc2ed46a97021d4916bf9495618.tar.gz
gentoo-34a5885d1e885fc2ed46a97021d4916bf9495618.tar.bz2
gentoo-34a5885d1e885fc2ed46a97021d4916bf9495618.zip
dev-perl/Mojolicious: Bump to version 8.570.0
- Fix LICENSE - Include Cpanel-JSON-XS dep w/o USE=minimal, as it gives a perf benefit for JSON code, and JSON is now used in the IPC channel, so this probably helps a lot. Upstream: - Improve Mojo::Promise->map efficiency - Fix Mojo::Asset::Memory not changing temporary directory in `upgrade` event. - Add experimental Mojo::File->extname - Fix Mojolicious::Types considering 'dotfiles' to be file extensions - Add experimental Mojo::DOM::CSS support for ":scope" and ":has" pseudo-classes - Fix Mojo::DOM parsing `select` and `ruby` elements incorrectly - Fix Mojo::UserAgent::Transactor not inheriting compression settings across redirects. - Fix Mojolicious templates not being able to use 'continue;' perl keyword. - Fix Mojo::DOM::CSS failing to parse valid selectors - Fix "% end, begin" not working in Mojo::Template - Add support for YAML config files - Add module Plugin::NotYAMLConfig - `app` generator command now can use YAML config file - Fix proxy helpers ignoring response content in some cases - Fix Test::Mojo::attr_is with false value comparisons. - `app` and `lite_app` generators now use templates with sub sigs Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Mojolicious/Manifest1
-rw-r--r--dev-perl/Mojolicious/Mojolicious-8.580.0.ebuild34
-rw-r--r--dev-perl/Mojolicious/metadata.xml1
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Manifest b/dev-perl/Mojolicious/Manifest
index f92d900c9dc2..7152e1a7e717 100644
--- a/dev-perl/Mojolicious/Manifest
+++ b/dev-perl/Mojolicious/Manifest
@@ -10,3 +10,4 @@ DIST Mojolicious-8.20.tar.gz 764063 BLAKE2B 846bb3cfeac502d808f28f26921a73e09587
DIST Mojolicious-8.30.tar.gz 772067 BLAKE2B b7f21b780a113aea3978968979e67442664104b15c6711d7f68d2dcb068fbb005135acf1845b0aeb4d43c2158672aab853aa862ba2ed1889242266c9ce80733f SHA512 1823a095df339ccdfe74395bb3066627bd5e2a4e9e1b8d907ff716ef511bd834e09c0aa703a1e51f675d2125f2848a25fa4efb2f48f9c5dcbe1dc8a1d0c48ff5
DIST Mojolicious-8.40.tar.gz 776844 BLAKE2B 6fc2224d55c625cea4eae39fe440903a3924054f07755512f9d6ce7c17aec5152da8999a5de0a30f71a8deab931bd781374c4a0929f7fd65cb3dea5d0a1a89a4 SHA512 7a086f2d195798acb0697595575860ceb111a0d22062637e48fec087b2de19a504425d626b9fa2d4b3bb2ba3d6f63dc703e5acb8a3bd39ba73ea452e07d1c1dc
DIST Mojolicious-8.50.tar.gz 777007 BLAKE2B 858e7b1f8133ba093e025f9de2f27958063e18eb6f5b09c9928ad2533ef2de19b753e44dc8c3d23f63c4f6b80009c7caaafcdfb419c7b687bec806618d9290c2 SHA512 29864baefb9c7786c77e371c6e29a8f811e434815c07ea265804431cbe37ed8bfcbb7b8bd6a0cfd45ae5aca8e53225121d9f30cd46cac1e6e87ae042d791c6b5
+DIST Mojolicious-8.58.tar.gz 778040 BLAKE2B 80e36b370a89fc3712332e8322a4ef3083a82a2cf1bc798b7a48ee9afec17a19adb2c45774dd0588807f78aefcf147f28fe50c97fe4a66a71d652027931fc37e SHA512 bcd923955253e2d5b4b6dbef919dd3a960189f5724561232543cb0b5ae9e700fecea04851dd87092e04c22d6039940c45985eb23baa7977c794dc90bc58d0643
diff --git a/dev-perl/Mojolicious/Mojolicious-8.580.0.ebuild b/dev-perl/Mojolicious/Mojolicious-8.580.0.ebuild
new file mode 100644
index 000000000000..343d4f6cb0dd
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-8.580.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SRI
+DIST_VERSION=8.58
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+LICENSE="Artistic-2"
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/Cpanel-JSON-XS-4.90.0
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-Scalar-List-Utils-1.410.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod_coverage.t
+)
diff --git a/dev-perl/Mojolicious/metadata.xml b/dev-perl/Mojolicious/metadata.xml
index c756b793a80a..31e0a6ff8c2e 100644
--- a/dev-perl/Mojolicious/metadata.xml
+++ b/dev-perl/Mojolicious/metadata.xml
@@ -102,6 +102,7 @@
<remote-id type="cpan-module">Mojolicious::Plugin::HeaderCondition</remote-id>
<remote-id type="cpan-module">Mojolicious::Plugin::JSONConfig</remote-id>
<remote-id type="cpan-module">Mojolicious::Plugin::Mount</remote-id>
+ <remote-id type="cpan-module">Mojolicious::Plugin::NotYAMLConfig</remote-id>
<remote-id type="cpan-module">Mojolicious::Plugin::TagHelpers</remote-id>
<remote-id type="cpan-module">Mojolicious::Plugins</remote-id>
<remote-id type="cpan-module">Mojolicious::Renderer</remote-id>