summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-08 19:02:07 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-08 19:26:21 +1300
commit492bfc536949f4d478f8f59bcb6a7ee1016d1fa7 (patch)
treef557523c604911163574fe3544ddc1e38f86dc4c /dev-perl
parentdev-perl/Net-SSLeay: Bump to version 1.800.0 (diff)
downloadgentoo-492bfc536949f4d478f8f59bcb6a7ee1016d1fa7.tar.gz
gentoo-492bfc536949f4d478f8f59bcb6a7ee1016d1fa7.tar.bz2
gentoo-492bfc536949f4d478f8f59bcb6a7ee1016d1fa7.zip
dev-perl/Net-HTTP: Bump to version 6.120.0
Upstream: - Fix my_readline() hanging when keep-alive => 1 and response_size is an exact multiple of 1024 - Avoid ignoring pending data from Net::SSL Keywording: - Dropped amd64-fbsd and arm64 due to new dependencies Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Net-HTTP/Manifest1
-rw-r--r--dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild38
-rw-r--r--dev-perl/Net-HTTP/files/6.12-networktest.patch131
3 files changed, 170 insertions, 0 deletions
diff --git a/dev-perl/Net-HTTP/Manifest b/dev-perl/Net-HTTP/Manifest
index ebd7f68e8b31..0bc627a7380b 100644
--- a/dev-perl/Net-HTTP/Manifest
+++ b/dev-perl/Net-HTTP/Manifest
@@ -1 +1,2 @@
DIST Net-HTTP-6.09.tar.gz 17686 SHA256 52762b939d84806908ba544581c5708375f7938c3c0e496c128ca3fbc425e58d SHA512 ae36c8367206f18190237f9c6db417054b78f99cfa79cc651550d3612505faf9d31e415c8b32e7f87f4fd389ccaa0e23f62c3781f6f27485b7296b2fe48d7e45 WHIRLPOOL e29a0193e607507538d4e6c7e08808a4c5c8a58d035fa3054a82fc9e148105961de8a8b12c5dff485246a0f4b97075832785ddfa992cce7720d7e56047ef631c
+DIST Net-HTTP-6.12.tar.gz 29548 SHA256 8565aff76b3d09084642f3a83c654fb4ced8220e8e19d35c78b661519b4c1be6 SHA512 5353f1c5914f90338f05342904224ff7998133e025de4389a68e9abf521040a1f9bb4c9b8c13f65bb014947fc3186c1d7e078a699f40a3edf5afed3a0da8746d WHIRLPOOL a19a97e4b4a6c7aae425bb20926cfc485417a63b60745b13d266fab36857b03dd3da2390ae468fd0d305db808df0521796571e13093b15ea8be46d1ad5d271b9
diff --git a/dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild b/dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild
new file mode 100644
index 000000000000..5c86654bb6b5
--- /dev/null
+++ b/dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.12
+inherit perl-module
+
+DESCRIPTION="Low-level HTTP connection (client)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal test"
+
+PATCHES=( "${FILESDIR}/${DIST_VERSION}-networktest.patch" )
+RDEPEND="
+ !minimal? (
+ virtual/perl-IO-Socket-IP
+ dev-perl/IO-Socket-INET6
+ >=dev-perl/IO-Socket-SSL-1.380.0
+ )
+ virtual/perl-Carp
+ !<dev-perl/libwww-perl-6
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-IO
+ virtual/perl-IO-Compress
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Socket
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Net-HTTP/files/6.12-networktest.patch b/dev-perl/Net-HTTP/files/6.12-networktest.patch
new file mode 100644
index 000000000000..3b67a939fe64
--- /dev/null
+++ b/dev-perl/Net-HTTP/files/6.12-networktest.patch
@@ -0,0 +1,131 @@
+From 3cfadd0fd690678e57eb5b6d1e0528724195238d Mon Sep 17 00:00:00 2001
+From: Olaf Alders <olaf@wundersolutions.com>
+Date: Thu, 29 Dec 2016 22:25:12 -0500
+Subject: [PATCH 1/2] Allow for 302s in live tests.
+
+---
+ t/live-https.t | 7 ++-----
+ t/live.t | 7 ++-----
+ 2 files changed, 4 insertions(+), 10 deletions(-)
+
+diff --git a/t/live-https.t b/t/live-https.t
+index 3482bbf..82e3b3d 100644
+--- a/t/live-https.t
++++ b/t/live-https.t
+@@ -63,12 +63,9 @@ for ( 1 .. 2 ) {
+ $buf .= $tmp;
+ }
+ $buf =~ s/\r//g;
+-
+- # ( my $out = $buf ) =~ s/^/# /gm;
+- # print $out;
+
+- is( $code, "200" );
++ ok( $code == 302 || $code == 200, 'success' );
+ like( $h{'Content-Type'}, qr{text/html} );
+- like( $buf, qr{</html>} );
++ like( $buf, qr{</html>}i );
+ }
+
+diff --git a/t/live.t b/t/live.t
+index 747515a..9a8306d 100644
+--- a/t/live.t
++++ b/t/live.t
+@@ -57,12 +57,9 @@ for ( 1 .. 2 ) {
+ $buf .= $tmp;
+ }
+ $buf =~ s/\r//g;
+-
+- # ( my $out = $buf ) =~ s/^/# /gm;
+- # print $out;
+
+- is( $code, "200" );
++ ok( $code == 302 || $code == 200, 'success' );
+ like( $h{'Content-Type'}, qr{text/html} );
+- like( $buf, qr{</html>} );
++ like( $buf, qr{</html>}i );
+ }
+
+--
+2.11.0
+
+From e9e0dcfb01425e3f620312375eaa50c4d6d0e561 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 8 Jan 2017 17:54:44 +1300
+Subject: [PATCH 2/2] Use NO_NETWORK_TESTING env var to fence off live tests
+
+---
+ t/live-https.t | 4 ++--
+ t/live.t | 4 ++--
+ t/rt-112313.t | 25 ++++++++++++++++++++-----
+ 3 files changed, 24 insertions(+), 9 deletions(-)
+
+diff --git a/t/live-https.t b/t/live-https.t
+index 82e3b3d..7d5d258 100644
+--- a/t/live-https.t
++++ b/t/live-https.t
+@@ -1,6 +1,6 @@
+ BEGIN {
+- unless ( -f "t/LIVE_TESTS" || -f "LIVE_TESTS" ) {
+- print "1..0 # SKIP Live tests disabled; pass --live-tests to Makefile.PL to enable\n";
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ print "1..0 # SKIP Live tests disabled due to NO_NETWORK_TESTING\n";
+ exit;
+ }
+ eval {
+diff --git a/t/live.t b/t/live.t
+index 9a8306d..a7c2f9d 100644
+--- a/t/live.t
++++ b/t/live.t
+@@ -1,6 +1,6 @@
+ BEGIN {
+- unless ( -f "t/LIVE_TESTS" || -f "LIVE_TESTS" ) {
+- print "1..0 # SKIP Live tests disabled; pass --live-tests to Makefile.PL to enable\n";
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ print "1..0 # SKIP Live tests disabled due to NO_NETWORK_TESTING\n";
+ exit;
+ }
+ eval {
+diff --git a/t/rt-112313.t b/t/rt-112313.t
+index 365d498..f98040d 100644
+--- a/t/rt-112313.t
++++ b/t/rt-112313.t
+@@ -1,3 +1,23 @@
++BEGIN {
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ print "1..0 # SKIP Live tests disabled due to NO_NETWORK_TESTING\n";
++ exit;
++ }
++ eval {
++ require IO::Socket::INET;
++ my $s = IO::Socket::INET->new(
++ PeerHost => "httpbin.org:80",
++ Timeout => 5,
++ );
++ die "Can't connect: $@" unless $s;
++ };
++ if ($@) {
++ print "1..0 # SKIP Can't connect to httpbin.org\n";
++ print $@;
++ exit;
++ }
++}
++
+ use strict;
+ use warnings;
+ use Test::More;
+@@ -15,11 +35,6 @@ use Net::HTTP;
+ # So, we check that the reponse growth is only one byte after each iteration and also test multiple
+ # times across the 1024, 2048 and 3072 boundaries...
+
+-unless (-f "t/LIVE_TESTS" || -f "LIVE_TESTS")
+-{
+- print "1..0 # SKIP Live tests disabled; pass --live-tests to Makefile.PL to enable\n";
+- exit;
+-}
+
+ sub try
+ {
+--
+2.11.0
+