summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-30 22:04:31 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-30 22:05:01 +1200
commit50a282b1359ed1d8a3fa971308bae322d8d49f1f (patch)
treeaa5269419f8faf7d15c4eee3e7f6bbb465dc815d /dev-perl
parentprofiles: mask dev-tex/hlatex for removal (diff)
downloadgentoo-50a282b1359ed1d8a3fa971308bae322d8d49f1f.tar.gz
gentoo-50a282b1359ed1d8a3fa971308bae322d8d49f1f.tar.bz2
gentoo-50a282b1359ed1d8a3fa971308bae322d8d49f1f.zip
dev-perl/Digest-BubbleBabble: -r bump for EAPI7 + fixes
- EAPI7 - Remove unused/empty variable assignments - Strip bundled inc/ deps which aren't used Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Digest-BubbleBabble/Digest-BubbleBabble-0.20.0-r2.ebuild31
-rw-r--r--dev-perl/Digest-BubbleBabble/files/Digest-BubbleBabble-0.02-no-test-base.patch25
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/Digest-BubbleBabble/Digest-BubbleBabble-0.20.0-r2.ebuild b/dev-perl/Digest-BubbleBabble/Digest-BubbleBabble-0.20.0-r2.ebuild
new file mode 100644
index 000000000000..7d31c933c3b8
--- /dev/null
+++ b/dev-perl/Digest-BubbleBabble/Digest-BubbleBabble-0.20.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BTROTT
+DIST_VERSION=0.02
+inherit perl-module
+
+DESCRIPTION="Create bubble-babble fingerprints"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+"
+PATCHES=(
+ # https://github.com/btrott/Digest-BubbleBabble/pull/1
+ "${FILESDIR}/0.02-dot-in-inc.patch"
+ "${FILESDIR}/${PN}-0.02-no-test-base.patch"
+)
+PERL_RM_FILES=(
+ inc/Spiffy.pm
+ inc/Test/Base.pm
+ inc/Test/Base/Filter.pm
+ inc/Test/Builder.pm
+ inc/Test/Builder/Module.pm
+ inc/Test/More.pm
+ inc/Module/Install/TestBase.pm
+)
diff --git a/dev-perl/Digest-BubbleBabble/files/Digest-BubbleBabble-0.02-no-test-base.patch b/dev-perl/Digest-BubbleBabble/files/Digest-BubbleBabble-0.02-no-test-base.patch
new file mode 100644
index 000000000000..2ba4cb0474d8
--- /dev/null
+++ b/dev-perl/Digest-BubbleBabble/files/Digest-BubbleBabble-0.02-no-test-base.patch
@@ -0,0 +1,25 @@
+From 739c3ffbbeac48b7f86f1e028aae0767b13261f1 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 30 Jul 2020 21:58:28 +1200
+Subject: Don't auto-use Test::Base
+
+as there doesn't appear to be anything that actually uses any of this
+---
+ Makefile.PL | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 261085f..e7dd11b 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -6,7 +6,6 @@ readme_from 'lib/Digest/BubbleBabble.pm';
+
+ test_requires 'Test::More';
+
+-use_test_base;
+ auto_include_deps;
+ author_tests('xt');
+ auto_set_repository;
+--
+2.27.0
+