summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-11 10:44:03 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-11 11:24:55 +1200
commit58cc65d5953eb03f92f50091c0cc78197f34f1d1 (patch)
treee3ab2df16fe92913c3f04c2003d031d606bb190b /dev-perl
parentdev-python/pygresql: remove unused patch (diff)
downloadgentoo-58cc65d5953eb03f92f50091c0cc78197f34f1d1.tar.gz
gentoo-58cc65d5953eb03f92f50091c0cc78197f34f1d1.tar.bz2
gentoo-58cc65d5953eb03f92f50091c0cc78197f34f1d1.zip
dev-perl/Pod-Parser: -r bump for decollision glue for perl <5.32
- Provision virtual deps, which seems only sensible given this very module is an example of what happens upstream on a regular basis: core stuff that could be handled by a virtual gets ripped out and leave us to pick up the pieces. - Avoid installing "podselect" on perl <5.32, which already have this script, and thus, risks a collision (but installing this ebuild on perl 5.30 will still 'upgrade' the modules shipped in core due to its existing mechanisms Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Pod-Parser/Pod-Parser-1.630.0-r1.ebuild38
-rw-r--r--dev-perl/Pod-Parser/Pod-Parser-1.630.0.ebuild14
-rw-r--r--dev-perl/Pod-Parser/files/Pod-Parser-1.63-no-binscript.patch25
3 files changed, 63 insertions, 14 deletions
diff --git a/dev-perl/Pod-Parser/Pod-Parser-1.630.0-r1.ebuild b/dev-perl/Pod-Parser/Pod-Parser-1.630.0-r1.ebuild
new file mode 100644
index 000000000000..cd1951539a22
--- /dev/null
+++ b/dev-perl/Pod-Parser/Pod-Parser-1.630.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MAREKR
+DIST_VERSION=1.63
+inherit perl-module
+
+DESCRIPTION="POD filters and translators"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RDEPEND="
+ virtual/perl-File-Spec
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+src_prepare() {
+ # This avoids filename collision in /usr/bin on perl <5.32
+ # which previously had this script. But no decollisioning needed for the modules
+ # due to that already being handled by @INC stuff
+ # Though, it does mean that with this installed, the podselect shipped in perl <5.32
+ # will consume modules shipped by this ebuild, but that doesn't look very problematic
+ # looking at the code (its just a dumb shim with arg-parsing)
+ if has_version -r "<dev-lang/perl-5.32"; then
+ einfo "Stripping podselect for compat with perl <5.32";
+ perl_rm_files "scripts/podselect.PL" \
+ "t/pod/podselect.t"
+ eapply "${FILESDIR}/${PN}-1.63-no-binscript.patch"
+ fi
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Pod-Parser/Pod-Parser-1.630.0.ebuild b/dev-perl/Pod-Parser/Pod-Parser-1.630.0.ebuild
deleted file mode 100644
index 558479317b0b..000000000000
--- a/dev-perl/Pod-Parser/Pod-Parser-1.630.0.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DIST_AUTHOR=MAREKR
-DIST_VERSION=1.63
-inherit perl-module
-
-DESCRIPTION="POD filters and translators"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
diff --git a/dev-perl/Pod-Parser/files/Pod-Parser-1.63-no-binscript.patch b/dev-perl/Pod-Parser/files/Pod-Parser-1.63-no-binscript.patch
new file mode 100644
index 000000000000..20efa9b8ac24
--- /dev/null
+++ b/dev-perl/Pod-Parser/files/Pod-Parser-1.63-no-binscript.patch
@@ -0,0 +1,25 @@
+From c3049f6c575836f19ff234635cd9ac8cf23cc930 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 11 Aug 2020 10:13:39 +1200
+Subject: Don't compile podselect bin script
+
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 258f51e..e6cac08 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -31,7 +31,7 @@ $DISTMOD = 'Pod::Parser'; ## The "title" module of this distribution
+ );
+
+ ## The executable scripts to be installed
+-@SCRIPTS = qw( podselect
++@SCRIPTS = qw(
+ );
+ sub script($) { File::Spec->catfile ('scripts', @_) }
+ my @EXE_FILES = ();
+--
+2.28.0
+