summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-19 18:58:16 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-19 18:58:27 +1200
commit64892d8947f2080b4d3d7b310fac95f46d69aac1 (patch)
tree1f4f170fbf4f72d56ac37aa4a3a059ae950dab06 /dev-perl
parentdev-perl/Frontier-RPC: Rename from dev-perl/frontier-rpc (diff)
downloadgentoo-64892d8947f2080b4d3d7b310fac95f46d69aac1.tar.gz
gentoo-64892d8947f2080b4d3d7b310fac95f46d69aac1.tar.bz2
gentoo-64892d8947f2080b4d3d7b310fac95f46d69aac1.zip
dev-perl/Frontier-RPC: -r bump for EAPI7 and minor fixes
- EAPI7 - Remove 403 dead homepage on sourceforge (looks to be a case where sourceforge just inhibited directory listing, which was all they were using for this, files in that directory are still accessible, just the index no longer works) - Remove empty/unused variable assignments - Add USE="examples" Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Frontier-RPC/Frontier-RPC-0.07_beta4-r3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-perl/Frontier-RPC/Frontier-RPC-0.07_beta4-r3.ebuild b/dev-perl/Frontier-RPC/Frontier-RPC-0.07_beta4-r3.ebuild
new file mode 100644
index 000000000000..a5c1e90a4bfa
--- /dev/null
+++ b/dev-perl/Frontier-RPC/Frontier-RPC-0.07_beta4-r3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_VERSION=0.07b4
+DIST_AUTHOR=KMACLEOD
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perform remote procedure calls using extensible markup language"
+SRC_URI+=" http://perl-xml.sourceforge.net/xml-rpc/${PN}-${DIST_VERSION}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"