summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 13:41:05 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 13:41:29 +1200
commit7342ca9d8b694a94fbe478e513eeb0217d878e61 (patch)
tree639583addbea7e248c8b05d79a66bd2d9761ebaf /dev-perl
parentmedia-video/avidemux: add i18n tarball to fix compilation (diff)
downloadgentoo-7342ca9d8b694a94fbe478e513eeb0217d878e61.tar.gz
gentoo-7342ca9d8b694a94fbe478e513eeb0217d878e61.tar.bz2
gentoo-7342ca9d8b694a94fbe478e513eeb0217d878e61.zip
dev-perl/Mojolicious: Bump to version 8.400.0
Upstream: - Add Test::Mojo->attr_{is,isnt,like,unlike} - Mojolicious::Static->is_fresh now supports weak etags - Mojo::Base `-async` now `-async_await` due to fun parsing problems in perl. - Fix Mojo::Base where `-async_await` would not load Mojo::Promise - Add experimental Mojo::Util->humanize_bytes - Add experimental Mojo::ByteStream->humanize_bytes - Update Future::AsyncAwait requirement to 0.36 for tests - Plugin::DefaultHelpers proxy->{get,post,start}_p no longer experimental - Mojolicious::Renderer->{compress,min_compress_size} no longer experimental - Mojo::IOLoop::Stream `high_water_mark` no longer experimental - Mojolicious::Renderer->respond no longer experimental - Mojo::IOLoop::Stream->{bytes_waiting,can_write} no longer experimental - Mojo::Headers->dehop no longer experimental - Mojo::Util->scope_guard no longer experimental - Mojolicious::Validator size check now only requires one argument - Mojolicious::Validator now properly validates empty strings instead of ingoring them. - Fix plugin generator to not use an __END__ section - Add Mojolicious::Validator `not_empty` filter - Add Test::Mojo `handler` attribute - Add Test::Mojo->test - Improve extension testing in Test::Mojo - Improve uniqueness of `request_id` in Mojo::Message::Request - Add Mojo::Server::Daemon->keep_alive_timeout - Add `-k` option to daemon and prefork commands. - Add `keep_alive_timeout` setting to Hypnotoad - Increase default timeouts - Improve timeout setting peformance in Mojo::IOLoop::Stream - Improve ->again in various reactors to allow changing invocation time of active timers. - Fix support for 425 status in Mojo::Message::Response - Add Mojo::IOLoop::Subprocess->run_p - Fix Mojo::Server::Daemon getting keep-alive timeout instead of inactivity timeout on active connections. - Fix Mojo::UserAgent race condition where test servers would disconnect prematurely. - Fix support for disabling inactivity timeout in Mojo::UserAgent Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Mojolicious/Manifest1
-rw-r--r--dev-perl/Mojolicious/Mojolicious-8.400.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Manifest b/dev-perl/Mojolicious/Manifest
index 44decfd79a9d..7e4fa2a64a5e 100644
--- a/dev-perl/Mojolicious/Manifest
+++ b/dev-perl/Mojolicious/Manifest
@@ -8,3 +8,4 @@ DIST Mojolicious-8.0.tar.gz 748351 BLAKE2B d1fb38dbe26561247050d07b6108fe423921d
DIST Mojolicious-8.10.tar.gz 754007 BLAKE2B 2ac7887e431598e7347999180a5d9e46c76a42cb9e2452645ece188055a2a27608c6398a18045356e1d87489e63d95358fa4e16e8d3d3bb310cd40867bd25586 SHA512 e2cee767f6aba83668fd2c0c13a5aa7e11bbd07d42f7e7633cef3657705265066b787c62c23da9faf66f1110196412bec9e06584fc7790e14f73dbe46dc67c0f
DIST Mojolicious-8.20.tar.gz 764063 BLAKE2B 846bb3cfeac502d808f28f26921a73e09587df9a792ffb737cce9f8d2cdd5224f563a79aebdae67f8df50fee8bade687e875cf056510d26960b7852aad128326 SHA512 d5d178b428fc9df815106811c197f886845591819228aad2ef14cb6fad8c82e04479d434b4e4c7d2da042d868d624de7f2a0381ff0d1f82b7b60638feb4174d3
DIST Mojolicious-8.30.tar.gz 772067 BLAKE2B b7f21b780a113aea3978968979e67442664104b15c6711d7f68d2dcb068fbb005135acf1845b0aeb4d43c2158672aab853aa862ba2ed1889242266c9ce80733f SHA512 1823a095df339ccdfe74395bb3066627bd5e2a4e9e1b8d907ff716ef511bd834e09c0aa703a1e51f675d2125f2848a25fa4efb2f48f9c5dcbe1dc8a1d0c48ff5
+DIST Mojolicious-8.40.tar.gz 776844 BLAKE2B 6fc2224d55c625cea4eae39fe440903a3924054f07755512f9d6ce7c17aec5152da8999a5de0a30f71a8deab931bd781374c4a0929f7fd65cb3dea5d0a1a89a4 SHA512 7a086f2d195798acb0697595575860ceb111a0d22062637e48fec087b2de19a504425d626b9fa2d4b3bb2ba3d6f63dc703e5acb8a3bd39ba73ea452e07d1c1dc
diff --git a/dev-perl/Mojolicious/Mojolicious-8.400.0.ebuild b/dev-perl/Mojolicious/Mojolicious-8.400.0.ebuild
new file mode 100644
index 000000000000..6032506e0d9f
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-8.400.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SRI
+DIST_VERSION=8.40
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-JSON-PP-2.271.30
+ >=virtual/perl-Scalar-List-Utils-1.410.0
+ >=virtual/perl-Time-Local-1.200.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod_coverage.t
+)