summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-08 03:46:43 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-08 03:47:02 +1200
commit77cbf441b196346f50d1d3553415bf1bf677cb4f (patch)
tree8b010f36e3267fe46d84952f5f0780dc86e1b81a /dev-perl
parentdev-libs/libfmt: Cleanup old versions (diff)
downloadgentoo-77cbf441b196346f50d1d3553415bf1bf677cb4f.tar.gz
gentoo-77cbf441b196346f50d1d3553415bf1bf677cb4f.tar.bz2
gentoo-77cbf441b196346f50d1d3553415bf1bf677cb4f.zip
dev-perl/Crypt-SMIME: Bump to version 0.260.0
Upstream: - sign(), signonly(), encrypt(), check(), and decrypt() no longer truncate input on a NUL character. Security Note: - This may have security implications as it implies there may be scope for attacks where two sets of input would give the same output, due to content after the NUL not being part of the sign'ed content. I may be misunderstanding the problem, so please check the cited bug for details Bug: https://rt.cpan.org/Public/Bug/Display.html?id=133084 Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Crypt-SMIME/Crypt-SMIME-0.260.0.ebuild49
-rw-r--r--dev-perl/Crypt-SMIME/Manifest1
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SMIME/Crypt-SMIME-0.260.0.ebuild b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.260.0.ebuild
new file mode 100644
index 000000000000..8f92eb8b68c9
--- /dev/null
+++ b/dev-perl/Crypt-SMIME/Crypt-SMIME-0.260.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MIKAGE
+DIST_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="S/MIME message signing, verification, encryption and decryption"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.9:0 )
+ libressl? ( dev-libs/libressl )
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/ExtUtils-CChecker
+ >=virtual/perl-ExtUtils-Constant-0.230.0
+ test? (
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ !minimal? (
+ >=dev-perl/Test-Taint-1.60.0
+ >=dev-perl/Taint-Util-0.80.0
+ )
+ )
+"
+PERL_RM_FILES=(
+ t/boilerplate.t
+ t/manifest.t
+ t/dependencies.t
+ t/pod-coverage.t
+ t/pod.t
+)
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Crypt-SMIME/Manifest b/dev-perl/Crypt-SMIME/Manifest
index 92653336bd47..98fc49c6a995 100644
--- a/dev-perl/Crypt-SMIME/Manifest
+++ b/dev-perl/Crypt-SMIME/Manifest
@@ -1 +1,2 @@
DIST Crypt-SMIME-0.25.tar.gz 28029 BLAKE2B d1f2e3d016b3e0e997de0df5082082e3332201c409c6a7b429ba99d2feb19a15ea79a3f22c6c3f9b2d057a1a9d5ae6d06b78d2e92d3e898987114eb5450955f6 SHA512 84f61c247d095ad345a6c736120d11c516e776c5f4a599a4c275481c4bd4597fcb2e0a17da5dc3e111310d3f99f9f39fb0876477098d9e6d9eabd777d145176f
+DIST Crypt-SMIME-0.26.tar.gz 28171 BLAKE2B 30c38a91f41a82ad29616ccd0ac6388baa0a66591401f15dbd31286fb22742e9069f08ec7650c91e87888f8a5bcb009415c5a6cd993105409ccbd7565df2384f SHA512 6ed7493a304bfff9946b465f0efda3e7df2c956aa964312b4c2b77c45d2827fd02d391886614f70bb25e8c692690ca62f5deff2fd482c66af9cb1e1b7b906bae