summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-31 16:18:19 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-31 16:18:39 +1200
commit7901d55641fe65e48e829ff45d29fb3d3388c6b8 (patch)
tree8296dc05b0c8a36876e417241a38c146f1d8ee22 /dev-perl
parentsys-boot/lilo: EAPI 7 and add NVME support (diff)
downloadgentoo-7901d55641fe65e48e829ff45d29fb3d3388c6b8.tar.gz
gentoo-7901d55641fe65e48e829ff45d29fb3d3388c6b8.tar.bz2
gentoo-7901d55641fe65e48e829ff45d29fb3d3388c6b8.zip
dev-perl/Digest-MD2: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Fix LICENSE - Ensure CFLAGS passed to make/compile Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Digest-MD2/Digest-MD2-2.40.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-perl/Digest-MD2/Digest-MD2-2.40.0-r1.ebuild b/dev-perl/Digest-MD2/Digest-MD2-2.40.0-r1.ebuild
new file mode 100644
index 000000000000..7700416484c9
--- /dev/null
+++ b/dev-perl/Digest-MD2/Digest-MD2-2.40.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=2.04
+inherit perl-module
+
+DESCRIPTION="Perl interface to the MD2 Algorithm"
+LICENSE="|| ( Artistic GPL-1+ ) RSA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}