summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-06 22:07:59 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-06 22:08:37 +1300
commit83dde078362b66346e7bb659ef8cf250f548eb1b (patch)
tree6a0cfa1eaf43a505a24e2c711580d6198405007e /dev-perl
parentapp-office/scribus: Fix dos2unix incompatibility (diff)
downloadgentoo-83dde078362b66346e7bb659ef8cf250f548eb1b.tar.gz
gentoo-83dde078362b66346e7bb659ef8cf250f548eb1b.tar.bz2
gentoo-83dde078362b66346e7bb659ef8cf250f548eb1b.zip
dev-perl/DBI: Bump to version 1.636.0
- EAPI6 - Add USE="examples" - Removed restriction on parallel compilation and tests Upstream: - Fix compilation on threadperls <= 5.12 - Fix race condition in destroy tests - Handle UTF8 in RaiseError/PrintError correctly - Fix ShowErrorStatement showing the wrong statement - DBD::Gofer handles UTF8 STDIN/STDOUT correctly - Fix no-column fetchall_arrayref({}) failing to bind_columns by returning an empty set instead - Fix memory leak with tied CachedKids attribute cache - Fix commit() or rollback() raising fatal "panic: attempt to copy freed scalar" in non-null context. - Avoid spurious extra warning when passing undef to DBI::Profile as a Path. - SQL::Nano parser now ignores trailing semicolon - New dbh->selectall_array method akin for simplifed dereferencing. - Killed DBI::FAQ Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBI/DBI-1.636.0.ebuild33
-rw-r--r--dev-perl/DBI/Manifest1
-rw-r--r--dev-perl/DBI/metadata.xml2
3 files changed, 34 insertions, 2 deletions
diff --git a/dev-perl/DBI/DBI-1.636.0.ebuild b/dev-perl/DBI/DBI-1.636.0.ebuild
new file mode 100644
index 000000000000..a73e925d6447
--- /dev/null
+++ b/dev-perl/DBI/DBI-1.636.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=TIMB
+DIST_VERSION=1.636
+DIST_EXAMPLES=("ex/*")
+inherit perl-module eutils
+
+DESCRIPTION="Database independent interface for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/PlRPC-0.200.0
+ >=virtual/perl-Sys-Syslog-0.170.0
+ virtual/perl-File-Spec
+ !<=dev-perl/SQL-Statement-1.330.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-Test-Simple-0.900.0
+ )
+"
+src_test() {
+ perl_rm_files t/pod-coverage.t t/pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/DBI/Manifest b/dev-perl/DBI/Manifest
index 5f08f1dfe6ef..4bf0d2dbd636 100644
--- a/dev-perl/DBI/Manifest
+++ b/dev-perl/DBI/Manifest
@@ -1 +1,2 @@
DIST DBI-1.634.tar.gz 595020 SHA256 250712f385864818abfba409420d16d9ee61f1cc73ac85159d054a5ee86d1450 SHA512 42e2b94d5e4cdcd57aaa43519fa1464a4d7132ed09426bb8cb7092b0ee57edde168105a25d02dcdeb304c6bc13c1ad97bc27b54b5f6af05eeaba011d5dab3c44 WHIRLPOOL 53b4b8caa8161b6d6fd999b039c31018060e018bc1b0e24163017e1128db1b29e2c798f8d91e64d2e3653088fd502efb440f21ae0fd8754d3d29803ea405057d
+DIST DBI-1.636.tar.gz 595433 SHA256 8f7ddce97c04b4b7a000e65e5d05f679c964d62c8b02c94c1a7d815bb2dd676c SHA512 8d541ada1fabb7e82dd4f47c43edf79cc70c783ef3582a9911b13239734876aee9f27095f2526e6923d07b7ac86df48ee081af1ca6000df0559a13c75b6f6ed3 WHIRLPOOL 15f437a0288458b3405cdc6b8f08c0f89f72bc77776cbcae33eb3a25bb92b8b7b3aae6e1e12fee9aae81723425b307a0017d65186d066c374062e9c4455eaf02
diff --git a/dev-perl/DBI/metadata.xml b/dev-perl/DBI/metadata.xml
index c4bb752d03b1..162537fa5d08 100644
--- a/dev-perl/DBI/metadata.xml
+++ b/dev-perl/DBI/metadata.xml
@@ -71,7 +71,6 @@
<remote-id type="cpan-module">DBI::DBD::SqlEngine::db</remote-id>
<remote-id type="cpan-module">DBI::DBD::SqlEngine::dr</remote-id>
<remote-id type="cpan-module">DBI::DBD::SqlEngine::st</remote-id>
- <remote-id type="cpan-module">DBI::FAQ</remote-id>
<remote-id type="cpan-module">DBI::Gofer::Execute</remote-id>
<remote-id type="cpan-module">DBI::Gofer::Request</remote-id>
<remote-id type="cpan-module">DBI::Gofer::Response</remote-id>
@@ -90,7 +89,6 @@
<remote-id type="cpan-module">DBI::ProxyServer::db</remote-id>
<remote-id type="cpan-module">DBI::ProxyServer::dr</remote-id>
<remote-id type="cpan-module">DBI::ProxyServer::st</remote-id>
- <remote-id type="cpan-module">DBI::PurePerl</remote-id>
<remote-id type="cpan-module">DBI::SQL::Nano</remote-id>
<remote-id type="cpan-module">DBI::SQL::Nano::Statement_</remote-id>
<remote-id type="cpan-module">DBI::SQL::Nano::Table_</remote-id>