summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-09 23:48:21 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-10-09 23:49:01 +0200
commitb12f7b3b83729b4a144883996e628889c8a2df78 (patch)
treeda959eaaba7d1891d82b91fbd44262e855f080ad /dev-perl
parentxfce-extra/xfce4-screensaver: added ~ppc (diff)
downloadgentoo-b12f7b3b83729b4a144883996e628889c8a2df78.tar.gz
gentoo-b12f7b3b83729b4a144883996e628889c8a2df78.tar.bz2
gentoo-b12f7b3b83729b4a144883996e628889c8a2df78.zip
dev-perl/DBD-mysql: Drop old, vulnerable and masked versions.
Also drops embedded useflag support. Closes: https://bugs.gentoo.org/634192 Closes: https://bugs.gentoo.org/598048 Closes: https://bugs.gentoo.org/644174 Closes: https://bugs.gentoo.org/598060 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild49
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild68
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.41.0-r2.ebuild69
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild65
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild66
-rw-r--r--dev-perl/DBD-mysql/Manifest4
-rw-r--r--dev-perl/DBD-mysql/files/4.041-amvis-type-conversions.patch47
-rw-r--r--dev-perl/DBD-mysql/files/4.041-no-dot-inc.patch103
-rw-r--r--dev-perl/DBD-mysql/files/4.042-no-dot-inc.patch178
-rw-r--r--dev-perl/DBD-mysql/files/DBD-mysql-print_embedded_options.patch20
-rw-r--r--dev-perl/DBD-mysql/metadata.xml1
11 files changed, 0 insertions, 670 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild
deleted file mode 100644
index c167c867d202..000000000000
--- a/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MODULE_AUTHOR=CAPTTOFU
-MODULE_VERSION=4.032
-inherit eutils perl-module
-
-DESCRIPTION="The Perl DBD:mysql Module"
-
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="embedded test"
-
-RDEPEND="dev-perl/DBI
- dev-perl/Test-Deep
- <dev-db/mysql-connector-c-8.0:0=
- embedded? ( virtual/mysql[embedded] )
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-print_embedded_options.patch
-}
-
-src_configure() {
- if use test; then
- myconf="${myconf} --testdb=test \
- --testhost=localhost \
- --testuser=test \
- --testpassword=test"
- fi
- use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
- perl-module_src_configure
-}
-
-src_test() {
- einfo
- einfo "If tests fail, you have to configure your MySQL instance to create"
- einfo "and grant some privileges to the test user."
- einfo "You can run the following commands at the MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
- sleep 5
- perl-module_src_test
-}
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild
deleted file mode 100644
index 9ebdaccc60fc..000000000000
--- a/dev-perl/DBD-mysql/DBD-mysql-4.37.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=MICHIELB
-DIST_VERSION=4.037
-inherit eutils perl-module
-
-DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
-
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-# embedded=on disables ssl support
-# https://metacpan.org/source/MICHIELB/DBD-mysql-4.036/dbdimp.c#L1886
-REQUIRED_USE="?? ( embedded ssl )"
-IUSE="embedded test +ssl"
-
-RDEPEND=">=dev-perl/DBI-1.609.0
- <dev-db/mysql-connector-c-8.0:0=
- embedded? ( virtual/mysql[embedded] )
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-Data-Dumper
- test? (
- dev-perl/Test-Deep
- >=virtual/perl-Test-Simple-0.900.0
- virtual/perl-Time-HiRes
- )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-print_embedded_options.patch
-)
-
-src_configure() {
- if use test; then
- myconf="${myconf} --testdb=test \
- --testhost=localhost \
- --testuser=test \
- --testpassword=test"
- fi
- myconf="${myconf} --$(usex ssl ssl nossl)"
- use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
- perl-module_src_configure
-}
-
-# Parallel testing is broken as 2 tests create the same table
-# and mysql isn't acid compliant and can't limit visibility of tables
-# to a transaction...
-DIST_TEST="do"
-
-src_test() {
- einfo
- einfo "If tests fail, you have to configure your MySQL instance to create"
- einfo "and grant some privileges to the test user."
- einfo "You can run the following commands at the MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
- sleep 5
- perl_rm_files t/pod.t t/manifest.t
- # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
- # out why 60leaks.t fails
- perl-module_src_test
-}
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.41.0-r2.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.41.0-r2.ebuild
deleted file mode 100644
index 1595e68121f8..000000000000
--- a/dev-perl/DBD-mysql/DBD-mysql-4.41.0-r2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=MICHIELB
-DIST_VERSION=4.041
-inherit eutils perl-module
-
-DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-# embedded=on disables ssl support
-# https://metacpan.org/source/MICHIELB/DBD-mysql-4.036/dbdimp.c#L1886
-REQUIRED_USE="?? ( embedded ssl )"
-IUSE="embedded test +ssl"
-
-RDEPEND=">=dev-perl/DBI-1.609.0
- <dev-db/mysql-connector-c-8.0:0=
- embedded? ( virtual/mysql[embedded] )
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-Data-Dumper
- test? (
- dev-perl/Test-Deep
- >=virtual/perl-Test-Simple-0.900.0
- virtual/perl-Time-HiRes
- )
-"
-PATCHES=(
- "${FILESDIR}/${DIST_VERSION}-no-dot-inc.patch"
- "${FILESDIR}/${DIST_VERSION}-amvis-type-conversions.patch"
- "${FILESDIR}/${DIST_VERSION}-mariadb-10.2.patch"
-)
-src_configure() {
- if use test; then
- myconf="${myconf} --testdb=test \
- --testhost=localhost \
- --testuser=test \
- --testpassword=test"
- fi
- myconf="${myconf} --$(usex ssl ssl nossl)"
- use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
- perl-module_src_configure
-}
-
-# Parallel testing is broken as 2 tests create the same table
-# and mysql isn't acid compliant and can't limit visibility of tables
-# to a transaction...
-DIST_TEST="do"
-
-src_test() {
- einfo
- einfo "If tests fail, you have to configure your MySQL instance to create"
- einfo "and grant some privileges to the test user."
- einfo "You can run the following commands at the MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
- sleep 5
- perl_rm_files t/pod.t t/manifest.t
- # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
- # out why 60leaks.t fails
- perl-module_src_test
-}
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild
deleted file mode 100644
index f3a4883d4ce8..000000000000
--- a/dev-perl/DBD-mysql/DBD-mysql-4.41.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=MICHIELB
-DIST_VERSION=4.041
-inherit eutils perl-module
-
-DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
-
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-# embedded=on disables ssl support
-# https://metacpan.org/source/MICHIELB/DBD-mysql-4.036/dbdimp.c#L1886
-REQUIRED_USE="?? ( embedded ssl )"
-IUSE="embedded test +ssl"
-
-RDEPEND=">=dev-perl/DBI-1.609.0
- <dev-db/mysql-connector-c-8.0:0=
- embedded? ( virtual/mysql[embedded] )
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-Data-Dumper
- test? (
- dev-perl/Test-Deep
- >=virtual/perl-Test-Simple-0.900.0
- virtual/perl-Time-HiRes
- )
-"
-PATCHES=( "${FILESDIR}/${DIST_VERSION}-no-dot-inc.patch" )
-src_configure() {
- if use test; then
- myconf="${myconf} --testdb=test \
- --testhost=localhost \
- --testuser=test \
- --testpassword=test"
- fi
- myconf="${myconf} --$(usex ssl ssl nossl)"
- use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
- perl-module_src_configure
-}
-
-# Parallel testing is broken as 2 tests create the same table
-# and mysql isn't acid compliant and can't limit visibility of tables
-# to a transaction...
-DIST_TEST="do"
-
-src_test() {
- einfo
- einfo "If tests fail, you have to configure your MySQL instance to create"
- einfo "and grant some privileges to the test user."
- einfo "You can run the following commands at the MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
- sleep 5
- perl_rm_files t/pod.t t/manifest.t
- # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
- # out why 60leaks.t fails
- perl-module_src_test
-}
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild
deleted file mode 100644
index 40d76fff1f44..000000000000
--- a/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=MICHIELB
-DIST_VERSION=4.042
-inherit eutils perl-module
-
-DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~s390 ~sh ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-# embedded=on disables ssl support
-# https://metacpan.org/source/MICHIELB/DBD-mysql-4.036/dbdimp.c#L1886
-REQUIRED_USE="?? ( embedded ssl )"
-IUSE="embedded test +ssl"
-
-RDEPEND=">=dev-perl/DBI-1.609.0
- <dev-db/mysql-connector-c-8.0:0=
- embedded? ( virtual/mysql[embedded] )
-"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-Data-Dumper
- dev-perl/Devel-CheckLib
- test? (
- dev-perl/Test-Deep
- >=virtual/perl-Test-Simple-0.900.0
- virtual/perl-Time-HiRes
- )
-"
-PATCHES=( "${FILESDIR}/${DIST_VERSION}-no-dot-inc.patch" )
-src_configure() {
- if use test; then
- myconf="${myconf} --testdb=test \
- --testhost=localhost \
- --testuser=test \
- --testpassword=test"
- fi
- myconf="${myconf} --$(usex ssl ssl nossl)"
- use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
- perl-module_src_configure
-}
-
-# Parallel testing is broken as 2 tests create the same table
-# and mysql isn't acid compliant and can't limit visibility of tables
-# to a transaction...
-DIST_TEST="do"
-
-src_test() {
- einfo
- einfo "If tests fail, you have to configure your MySQL instance to create"
- einfo "and grant some privileges to the test user."
- einfo "You can run the following commands at the MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
- sleep 5
- perl_rm_files t/pod.t t/manifest.t
- # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
- # out why 60leaks.t fails
- perl-module_src_test
-}
diff --git a/dev-perl/DBD-mysql/Manifest b/dev-perl/DBD-mysql/Manifest
index 8d20e4393055..7658903db072 100644
--- a/dev-perl/DBD-mysql/Manifest
+++ b/dev-perl/DBD-mysql/Manifest
@@ -1,6 +1,2 @@
-DIST DBD-mysql-4.032.tar.gz 146476 BLAKE2B 3ace983522e273cdb18352d2fa87702222594daed6e8d1eda2b037e5b98c31fd2e81bfa57ec71d6f5d836de80cdaf06a3571ae7c84d1ff4822ed6ab4f5d9e8fe SHA512 7e7ebaed07f0540079854294cc3ab4a4554fd0f850dd0927b2485cc985c2c9f5b70a650d971027c883cc4d8450020245656f6ff1f792a56d1a2d4b45402d73d0
-DIST DBD-mysql-4.037.tar.gz 146639 BLAKE2B fbecca7302cd6ea0386116a1824a7696f87f681dbfcd88970b1a5eab54639e46471fc07b37bd8c0158b3eca02d05dad159e11027daa5ab46eaa307b530f7c58e SHA512 3bda6ea18d29e32028b7eb93cd06fdbabbadafa66f982556298a68980c42a7b5236872113696e6d2df66a345049d1e63bc90ab358c8631f0cbea187780e514af
-DIST DBD-mysql-4.041.tar.gz 150508 BLAKE2B 900ccc4ad9bc5bfb236c66774a6c9529beed3568c3f3626afcbb572fa530a2488ee8e05b1dabd169a775f28d634321dd3e86923e2829e019943a9f3054b1e887 SHA512 8663c58f1dec273869ef5d3ee663d80cb36fa87b1956318fff07a4a801aaecc395510a8f31b7a51b823f7e9d6a73ebf13894c1b7f7b27fdc3f3956e6aba34777
-DIST DBD-mysql-4.042.tar.gz 160028 BLAKE2B ef2f9d6508a473c34275ae9d7233863698ab502d837975f08593d2d1ca9761081ffb84bafc5a02c572e2a6b4d54dd7c8312e476e0719733166f8edc030a016de SHA512 fe3c9e1e325f7056da783e0ea33f9a7810f25f3d9cd2c9a4bf4037b20a2148f2291b2f90d44730e63c7902b45e26993a7f9fcf1b3bf8d1bc5d3fca99893a019e
DIST DBD-mysql-4.044.tar.gz 155006 BLAKE2B 2934224010bb09aaff9a334b25038a4c7d1eb5552f6ad2b73f44aa7e2d8cb3684644773a89f35363c156cf40867a28943320e1b8b7ef4b9d4b8ac0f6b2417b38 SHA512 e3dd9482e8f78c19dc91baba07e39e266f113ce5a014cfe6c5989c96ed0f85723a17ba6a6e00b65a1ed3c62362400bd3779eb63ed282f73587b4757da249af02
DIST DBD-mysql-4.050.tar.gz 161579 BLAKE2B fb17e151db730fd6955d3e4424dd495a9fcf5f3f4e2b6b79d9fdc86bc42c3314b68771f1d3c393fd80ea14aeda626a5c5d21f5b921d487350ffd79802edab1f6 SHA512 910f5b4ba7a7890d50a79f37d04ec8971a4f62acd0fe30bf3ab634f66e3128f0cd6513e5c9da8c807a0f4477d0cc766682ea8dd0d8072d02821b78df51f37879
diff --git a/dev-perl/DBD-mysql/files/4.041-amvis-type-conversions.patch b/dev-perl/DBD-mysql/files/4.041-amvis-type-conversions.patch
deleted file mode 100644
index 041ba0a496a6..000000000000
--- a/dev-perl/DBD-mysql/files/4.041-amvis-type-conversions.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From: Pali <pali@cpan.org>
-Date: Fri, 24 Feb 2017 19:51:36 +0100
-Subject: [PATCH] Fix type conversions
-
-Calling SvNV() for magical scalar is not enough for float type conversion.
-It caused problem for Amavis in tainted mode -- all float values were zero.
-On the other hand SvIV() and SvUV() seems to work fine. To be sure that
-correct value of float is in scalar use sv_setnv() with explicit NV float
-value. Similar code is changed also for integers IV/UV.
-
-This patch should fix reported Amavis bug:
-https://github.com/perl5-dbi/DBD-mysql/issues/78
-
-See also reported perl bug about SvNV():
-https://rt.perl.org/Public/Bug/Display.html?id=130801
-
-Bugs: https://github.com/perl5-dbi/DBD-mysql/issues/78
-Bugs-Debian: https://bugs.debian.org/856064
-
---- a/dbdimp.c
-+++ b/dbdimp.c
-@@ -4250,8 +4250,7 @@
- switch (mysql_to_perl_type(fields[i].type)) {
- case MYSQL_TYPE_DOUBLE:
- /* Coerce to dobule and set scalar as NV */
-- (void) SvNV(sv);
-- SvNOK_only(sv);
-+ sv_setnv(sv, SvNV(sv));
- break;
-
- case MYSQL_TYPE_LONG:
-@@ -4259,13 +4258,11 @@
- /* Coerce to integer and set scalar as UV resp. IV */
- if (fields[i].flags & UNSIGNED_FLAG)
- {
-- (void) SvUV(sv);
-- SvIOK_only_UV(sv);
-+ sv_setuv(sv, SvUV(sv));
- }
- else
- {
-- (void) SvIV(sv);
-- SvIOK_only(sv);
-+ sv_setiv(sv, SvIV(sv));
- }
- break;
-
diff --git a/dev-perl/DBD-mysql/files/4.041-no-dot-inc.patch b/dev-perl/DBD-mysql/files/4.041-no-dot-inc.patch
deleted file mode 100644
index f26837f548a8..000000000000
--- a/dev-perl/DBD-mysql/files/4.041-no-dot-inc.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-From 497224cad8b6469913c61ee856228bc1d0280980 Mon Sep 17 00:00:00 2001
-From: Pali <pali@cpan.org>
-Date: Mon, 17 Apr 2017 21:38:58 +0200
-Subject: [PATCH] Fix tests on Perl On 5.25.10 or greater with
- -Ddefault_inc_excludes_dot
-
-Some tests do not include dot in %INC and fails with error:
-Can't locate t/lib.pl in @INC
-
-Fixes: https://rt.cpan.org/Public/Bug/Display.html?id=120709
----
- t/40server_prepare_crash.t | 3 ++-
- t/rt25389-bin-case.t | 3 ++-
- t/rt50304-column_info_parentheses.t | 3 ++-
- t/rt61849-bind-param-buffer-overflow.t | 3 ++-
- t/rt75353-innodb-lock-timeout.t | 3 ++-
- t/rt83494-quotes-comments.t | 3 ++-
- 11 files changed, 22 insertions(+), 11 deletions(-)
-
-diff --git a/t/40server_prepare_crash.t b/t/40server_prepare_crash.t
-index e3777b9..d04eb9c 100644
---- a/t/40server_prepare_crash.t
-+++ b/t/40server_prepare_crash.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { PrintError => 1, RaiseError => 1, AutoCommit => 0, mysql_server_prepare => 1, mysql_server_prepare_disable_fallback => 1 });
- plan skip_all => "You must have MySQL version 4.1.3 and greater for this test to run" if $dbh->{mysql_clientversion} < 40103 or $dbh->{mysql_serverversion} < 40103;
-diff --git a/t/rt25389-bin-case.t b/t/rt25389-bin-case.t
-index cbda8b7..3aee41b 100644
---- a/t/rt25389-bin-case.t
-+++ b/t/rt25389-bin-case.t
-@@ -4,7 +4,8 @@ use warnings;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- use Test::More;
-
-diff --git a/t/rt50304-column_info_parentheses.t b/t/rt50304-column_info_parentheses.t
-index 76f9eff..6c3aac5 100644
---- a/t/rt50304-column_info_parentheses.t
-+++ b/t/rt50304-column_info_parentheses.t
-@@ -4,7 +4,8 @@ use warnings;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password $state);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- use Test::More;
-
-diff --git a/t/rt61849-bind-param-buffer-overflow.t b/t/rt61849-bind-param-buffer-overflow.t
-index 82baf2f..a3c75de 100644
---- a/t/rt61849-bind-param-buffer-overflow.t
-+++ b/t/rt61849-bind-param-buffer-overflow.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $INSECURE_VALUE_FROM_USER = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
-
-diff --git a/t/rt75353-innodb-lock-timeout.t b/t/rt75353-innodb-lock-timeout.t
-index a1f437d..95694db 100644
---- a/t/rt75353-innodb-lock-timeout.t
-+++ b/t/rt75353-innodb-lock-timeout.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh1 = DbiTestConnect($test_dsn, $test_user, $test_password, { RaiseError => 1, AutoCommit => 0 });
-
-diff --git a/t/rt83494-quotes-comments.t b/t/rt83494-quotes-comments.t
-index c48b0b9..83919f2 100644
---- a/t/rt83494-quotes-comments.t
-+++ b/t/rt83494-quotes-comments.t
-@@ -9,7 +9,8 @@ use DBI;
- use Test::More;
-
- use vars qw($test_dsn $test_user $test_password $state);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password,
- { RaiseError => 1, PrintError => 0, AutoCommit => 0 });
diff --git a/dev-perl/DBD-mysql/files/4.042-no-dot-inc.patch b/dev-perl/DBD-mysql/files/4.042-no-dot-inc.patch
deleted file mode 100644
index 274605c44c7d..000000000000
--- a/dev-perl/DBD-mysql/files/4.042-no-dot-inc.patch
+++ /dev/null
@@ -1,178 +0,0 @@
-From 497224cad8b6469913c61ee856228bc1d0280980 Mon Sep 17 00:00:00 2001
-From: Pali <pali@cpan.org>
-Date: Mon, 17 Apr 2017 21:38:58 +0200
-Subject: [PATCH] Fix tests on Perl On 5.25.10 or greater with
- -Ddefault_inc_excludes_dot
-
-Some tests do not include dot in %INC and fails with error:
-Can't locate t/lib.pl in @INC
-
-Fixes: https://rt.cpan.org/Public/Bug/Display.html?id=120709
----
- t/40server_prepare_crash.t | 3 ++-
- t/55utf8_jp.t | 3 ++-
- t/cve-2017-3302.t | 3 ++-
- t/magic.t | 3 ++-
- t/rt110983-valid-mysqlfd.t | 3 ++-
- t/rt118977-zerofill.t | 3 ++-
- t/rt25389-bin-case.t | 3 ++-
- t/rt50304-column_info_parentheses.t | 3 ++-
- t/rt61849-bind-param-buffer-overflow.t | 3 ++-
- t/rt75353-innodb-lock-timeout.t | 3 ++-
- t/rt83494-quotes-comments.t | 3 ++-
- 11 files changed, 22 insertions(+), 11 deletions(-)
-
-diff --git a/t/40server_prepare_crash.t b/t/40server_prepare_crash.t
-index e3777b9..d04eb9c 100644
---- a/t/40server_prepare_crash.t
-+++ b/t/40server_prepare_crash.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { PrintError => 1, RaiseError => 1, AutoCommit => 0, mysql_server_prepare => 1, mysql_server_prepare_disable_fallback => 1 });
- plan skip_all => "You must have MySQL version 4.1.3 and greater for this test to run" if $dbh->{mysql_clientversion} < 40103 or $dbh->{mysql_serverversion} < 40103;
-diff --git a/t/55utf8_jp.t b/t/55utf8_jp.t
-index 638d494..88874c3 100644
---- a/t/55utf8_jp.t
-+++ b/t/55utf8_jp.t
-@@ -6,7 +6,8 @@ use DBI;
- use Encode;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { mysql_enable_utf8 => 1, PrintError => 1, RaiseError => 1 });
-
-diff --git a/t/cve-2017-3302.t b/t/cve-2017-3302.t
-index b2de927..fbca0e3 100644
---- a/t/cve-2017-3302.t
-+++ b/t/cve-2017-3302.t
-@@ -6,7 +6,8 @@ if ($ENV{SKIP_CRASH_TESTING}) {
- no warnings 'once';
- use DBI;
- use vars qw($test_dsn $test_user $test_password $test_db);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
- eval {
- $dbh = DBI->connect($test_dsn, $test_user, $test_password, {RaiseError => 1, mysql_server_prepare => 1});
- } or do {
-diff --git a/t/magic.t b/t/magic.t
-index 2720655..a7978a4 100644
---- a/t/magic.t
-+++ b/t/magic.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $tb = Test::More->builder;
- binmode $tb->failure_output, ":utf8";
-diff --git a/t/rt110983-valid-mysqlfd.t b/t/rt110983-valid-mysqlfd.t
-index ad59762..12dace7 100644
---- a/t/rt110983-valid-mysqlfd.t
-+++ b/t/rt110983-valid-mysqlfd.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { RaiseError => 1, AutoCommit => 0 });
-
-diff --git a/t/rt118977-zerofill.t b/t/rt118977-zerofill.t
-index 1992c4c..328766b 100644
---- a/t/rt118977-zerofill.t
-+++ b/t/rt118977-zerofill.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password, { PrintError => 1, RaiseError => 1 });
-
-diff --git a/t/rt25389-bin-case.t b/t/rt25389-bin-case.t
-index cbda8b7..3aee41b 100644
---- a/t/rt25389-bin-case.t
-+++ b/t/rt25389-bin-case.t
-@@ -4,7 +4,8 @@ use warnings;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- use Test::More;
-
-diff --git a/t/rt50304-column_info_parentheses.t b/t/rt50304-column_info_parentheses.t
-index 76f9eff..6c3aac5 100644
---- a/t/rt50304-column_info_parentheses.t
-+++ b/t/rt50304-column_info_parentheses.t
-@@ -4,7 +4,8 @@ use warnings;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password $state);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- use Test::More;
-
-diff --git a/t/rt61849-bind-param-buffer-overflow.t b/t/rt61849-bind-param-buffer-overflow.t
-index 82baf2f..a3c75de 100644
---- a/t/rt61849-bind-param-buffer-overflow.t
-+++ b/t/rt61849-bind-param-buffer-overflow.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $INSECURE_VALUE_FROM_USER = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
-
-diff --git a/t/rt75353-innodb-lock-timeout.t b/t/rt75353-innodb-lock-timeout.t
-index a1f437d..95694db 100644
---- a/t/rt75353-innodb-lock-timeout.t
-+++ b/t/rt75353-innodb-lock-timeout.t
-@@ -5,7 +5,8 @@ use Test::More;
- use DBI;
-
- use vars qw($test_dsn $test_user $test_password);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh1 = DbiTestConnect($test_dsn, $test_user, $test_password, { RaiseError => 1, AutoCommit => 0 });
-
-diff --git a/t/rt83494-quotes-comments.t b/t/rt83494-quotes-comments.t
-index c48b0b9..83919f2 100644
---- a/t/rt83494-quotes-comments.t
-+++ b/t/rt83494-quotes-comments.t
-@@ -9,7 +9,8 @@ use DBI;
- use Test::More;
-
- use vars qw($test_dsn $test_user $test_password $state);
--require "t/lib.pl";
-+use lib 't', '.';
-+require "lib.pl";
-
- my $dbh = DbiTestConnect($test_dsn, $test_user, $test_password,
- { RaiseError => 1, PrintError => 0, AutoCommit => 0 });
diff --git a/dev-perl/DBD-mysql/files/DBD-mysql-print_embedded_options.patch b/dev-perl/DBD-mysql/files/DBD-mysql-print_embedded_options.patch
deleted file mode 100644
index d205b43f33ec..000000000000
--- a/dev-perl/DBD-mysql/files/DBD-mysql-print_embedded_options.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -ubBr old/dbdimp.c new/dbdimp.c
---- old/dbdimp.c 2015-09-12 17:52:41.328543844 -0400
-+++ new/dbdimp.c 2015-09-12 23:21:52.848371578 -0400
-@@ -443,14 +443,14 @@
- Print out embbedded option settings
-
- */
--int print_embedded_options(char ** options_list, int options_count)
-+int print_embedded_options(PerlIOl ** Log, char ** options_list, int options_count)
- {
- int i;
-
- for (i=0; i<options_count; i++)
- {
- if (options_list[i])
-- PerlIO_printf(DBILOGFP,
-+ PerlIO_printf(Log,
- "Embedded server, parameter[%d]=%s\n",
- i, options_list[i]);
- }
diff --git a/dev-perl/DBD-mysql/metadata.xml b/dev-perl/DBD-mysql/metadata.xml
index 59ac82b1e1b2..08306e46bf97 100644
--- a/dev-perl/DBD-mysql/metadata.xml
+++ b/dev-perl/DBD-mysql/metadata.xml
@@ -15,7 +15,6 @@
<remote-id type="cpan-module">DBD::mysql::st</remote-id>
</upstream>
<use>
- <flag name="embedded">Support embedded server (libmysqld)</flag>
<flag name="ssl">Compile in support for SSL connections via libmysqlclient</flag>
<flag name="mariadb">Use <pkg>dev-db/mariadb-connector-c</pkg> as the client library</flag>
<flag name="mysql">Use <pkg>dev-db/mysql-connector-c</pkg> as the client library</flag>