summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 22:15:02 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 22:15:20 +1200
commitbc5f80ad3f5e573e3774d3749a79b493d993eba7 (patch)
treede8aff03067b603d609e3c3039d56f9dc67065b5 /dev-perl
parentdev-python/sphinxcontrib-spelling: Bump to 5.2.2 (diff)
downloadgentoo-bc5f80ad3f5e573e3774d3749a79b493d993eba7.tar.gz
gentoo-bc5f80ad3f5e573e3774d3749a79b493d993eba7.tar.bz2
gentoo-bc5f80ad3f5e573e3774d3749a79b493d993eba7.zip
dev-perl/Encode-Detect: -r bump for EAPI7 + Fixes
- EAPI7 - Fix redundancy in DESCRIPTION - Fix LICENSE - Remove empty/unused variable assignments - Parallel tests - Guard against LD!=ccld breaking code re bug #720788 - Ensure CFLAGS passed to compiler Bug: https://bugs.gentoo.org/720788 Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Encode-Detect/Encode-Detect-1.10.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Encode-Detect/Encode-Detect-1.10.0-r2.ebuild b/dev-perl/Encode-Detect/Encode-Detect-1.10.0-r2.ebuild
new file mode 100644
index 000000000000..be2a45f86517
--- /dev/null
+++ b/dev-perl/Encode-Detect/Encode-Detect-1.10.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=JGMYERS
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="An Encode::Encoding subclass that detects the encoding of data"
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+DEPEND="dev-perl/Module-Build"
+BDEPEND="
+ dev-perl/Module-Build
+ virtual/perl-ExtUtils-CBuilder
+"
+src_configure() {
+ unset LD
+ [[ -n "${CCLD}" ]] && export LD="${CCLD}"
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}