summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-30 22:23:11 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-30 22:23:22 +1200
commitd6e1b77bb0e4d7fc1e4650a55bb0abeb0c9fa6ce (patch)
tree634b8f2927d254af17249fe1438d7f68d7b1687b /dev-perl
parentprofiles: mask dev-tex/slatex for removal (diff)
downloadgentoo-d6e1b77bb0e4d7fc1e4650a55bb0abeb0c9fa6ce.tar.gz
gentoo-d6e1b77bb0e4d7fc1e4650a55bb0abeb0c9fa6ce.tar.bz2
gentoo-d6e1b77bb0e4d7fc1e4650a55bb0abeb0c9fa6ce.zip
dev-perl/Digest-GOST: -r bump for EAPI7 & CFLAGS love
- EAPI7 - Ensure CFLAGS passed to make/compiler Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Digest-GOST/Digest-GOST-0.60.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Digest-GOST/Digest-GOST-0.60.0-r2.ebuild b/dev-perl/Digest-GOST/Digest-GOST-0.60.0-r2.ebuild
new file mode 100644
index 000000000000..93c4b19d60b4
--- /dev/null
+++ b/dev-perl/Digest-GOST/Digest-GOST-0.60.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GRAY
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Perl interface to the GOST R 34.11-94 digest algorithm"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Digest
+ virtual/perl-XSLoader
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.820.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${P}-bigendian-link.patch"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}