summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 10:37:33 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 10:37:49 +1200
commite696faccf91fdc9dd44cac943a1cc2552cc24373 (patch)
tree24ff6a626c9ed8f437dab43272cab7d27dc51bc8 /dev-perl
parentnet-irc/inspircd: Drop v3.6.0 (diff)
downloadgentoo-e696faccf91fdc9dd44cac943a1cc2552cc24373.tar.gz
gentoo-e696faccf91fdc9dd44cac943a1cc2552cc24373.tar.bz2
gentoo-e696faccf91fdc9dd44cac943a1cc2552cc24373.zip
dev-perl/Mojolicious: Bump to version 7.800.0
Upstream: - Mojo::UserAgent now verifies and rejects all invalid TLS certificates unless the user specifies $ua->insecure(1) - Test::Mojo defaults to being insecure for easier testing - `mojo get` now supports -k option (similar to `curl -k`) to allow fetching from invalid TLS URLs - Mojo::IOLoop::TLS no longer has a default tls_verify value, instead, disabling TLS verification is done with $tls->negotiate(tls_verify => 0x00) - Add Mojo::UserAgent->insecure - Add experimental server method to Mojolicious - Add experimental `before_server_start` hook - Fix bug where Mojo::DOM could only reuse Mojo::DOM objects containing root nodes - Add experimental Mojo::DOM->selector - Add reply->file helper to Plugin::DefaultHelpers - Deprecated delay helper in Plugin::DefaultHelpers - Add experimental Mojo::DOM->new_tag - Add experimental Mojo::DOM::HTML->{tag,tag_to_html} - All Mojo::DOM dom manipulation methods now faster then reusing Mojo::DOM objects - Fix windows directory traversal security issue - Support namespace selectors like "ns|*" in Mojo::DOM::CSS - Mojo::DOM::CSS supports ":link" and ":visited" pseudo-classes - Mojo::DOM::CSS supports hyphen-seperated list attribute selectors like "[hreflang|=en]" to match hreflang="en-us" - Fix Plugin::Config stash value unavailability with config_overrides feature - Deprecated placeholder quoting with "(placeholder)" in favor of "<placeholder>" - Fix various Mojo::Collection warnings - Add support for routes with placeholder types - Add types attr to Mojolicious::Routes{,::Pattern} - Add Mojolicious::Rotes->add_type - Add Mojo::Asset{,::File,::Memory}->to_file - Add 'num' placeholder type to Mojolicious::Routes - Remove deprecated instance methods Mojo::Promise->{all,race} - Improve Mojo::Content::MultiPart performance with large numbers of parts. - Fix more source-ordering problems in Mojolicious::Renderer content negotiation - Deprecate Mojo::{build_tx,Config,handler,log} - Add Mojolicious->config - Fix exceptions cased by non-UTF8 files in Mojo::Exception Security: - Older versions did not by default reject invalid TLS certificates, but code now needs to explicitly opt-in to this weak-security behaviour with ->insecure(1) - On windows, due to the different use of path seperators than unix, would-be attackers could subvert the directory-traversal protection in Mojo, and this is now mitigated by bailing dispatch entirely if a windows directory seperator is seen in the static dispatch path Bug: https://github.com/mojolicious/mojo/pull/1217 Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Mojolicious/Manifest1
-rw-r--r--dev-perl/Mojolicious/Mojolicious-7.800.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Manifest b/dev-perl/Mojolicious/Manifest
index de3392cd06a3..0842184b9648 100644
--- a/dev-perl/Mojolicious/Manifest
+++ b/dev-perl/Mojolicious/Manifest
@@ -1,3 +1,4 @@
DIST Mojolicious-7.57.tar.gz 706093 BLAKE2B 13212367fe09a437a97093668558ded1216465b25dd145ecf7e62256f05f129a434164a346bb3e928482fc041acfd68350e9e71ac088c49f679df43221917f73 SHA512 2bb830ca14cda5571a614ad74144c047dd96fafe49b530b1e6e19115c43cc3b8f4f174f549fdb8816183e42f26620fcf36b47f7c05ae592273c74c38dfaa4c0b
DIST Mojolicious-7.60.tar.gz 708129 BLAKE2B bac0f8ac75255ed6d0597cc2d00eeca9da66e9c7548942daf50cca3d24875306a8e19934ae10b2e5b3bd727b1bb531b31a665938c32f861aacba6456fedf7779 SHA512 3e6e0ea266caf8e19546e587ce7bf4d8ef86fa0f2503ef7a1b97b2f4f4f55f9775894d1ad74dd4e84760a3c976f6b94451aa29260f9854d5cc3cefec512428a2
DIST Mojolicious-7.70.tar.gz 711260 BLAKE2B 0f471c2039b94ad74d60471d879c9993e2dbf16ed23c710c02786ffe6056d613ee4095668d0c34919fc9649815905d4d771cc4adb832ed2b37b3016d6398884e SHA512 2cda5b378d5c1899d78c199c7f1d3439a6fd697ab885bb4d337270256534ec68f9d73267199a6f72e9677049cf9cd6f239451cac31aebcf4743229419a82dd8b
+DIST Mojolicious-7.80.tar.gz 718598 BLAKE2B 955fb6253ef2957b9ef6828cd261374fd2f17386c4a426f9a3d73fc734e02f4297d088b70daa8c5e67892d4f4fc491b4a227e7f1420e461f5c2161eac5f0ff19 SHA512 f1149c4675377de09bd6db4355c251f3a8db2a81688a906e80c1978d6854a9d89120b39c824aef49934da48ac29d9e62e28940752ec608084dd2ffeee9116553
diff --git a/dev-perl/Mojolicious/Mojolicious-7.800.0.ebuild b/dev-perl/Mojolicious/Mojolicious-7.800.0.ebuild
new file mode 100644
index 000000000000..276c1aa9f5d0
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-7.800.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SRI
+DIST_VERSION=7.80
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-JSON-PP-2.271.30
+ >=virtual/perl-Pod-Simple-3.90.0
+ >=virtual/perl-Time-Local-1.200.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod_coverage.t
+)