summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-12 22:55:17 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 08:57:30 +1200
commiteab56389835de937b0b83f34e69136ff113685d1 (patch)
treec578125812366e1b164bc50ff9e9914c98f13ec8 /dev-perl
parentsci-libs/libhomfly: new library for homfly polynomial computation. (diff)
downloadgentoo-eab56389835de937b0b83f34e69136ff113685d1.tar.gz
gentoo-eab56389835de937b0b83f34e69136ff113685d1.tar.bz2
gentoo-eab56389835de937b0b83f34e69136ff113685d1.zip
dev-perl/Mojolicious: Bump to version 7.600.0
- EAPI7 - Unconditionally remove bad tests Upstream: - Deprecated Promise->{all,race} as instance methods - Improve Promise->{all,race} to handle arbitrary then-ables - Improve number detection in Mojo::JSON with workaround for some breaking changes in Perl 5.28 - Improve Mojo::DOM::HTML compliance with HTML Living Standard - Fix multi-role composition bug in Mojo::Base - Fix DATA sections in Mojolicious::Static where text files are not UTF-8 encoded as they should be. - Moved 'home' and 'ua' attributes from 'Mojo' to 'Mojolicious' - Mojo::IOLoop::Client only starts a threadpool with Net::DNS::Native on demand - Improved role composition with Mojo::IOLoop - Fix RFC 7230 complaiance in Mojo::Message::Response - Add Mojo::UserAgent->websocket_p Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Mojolicious/Manifest1
-rw-r--r--dev-perl/Mojolicious/Mojolicious-7.600.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Manifest b/dev-perl/Mojolicious/Manifest
index 50c95ebbc3f5..b1bb95f1c6de 100644
--- a/dev-perl/Mojolicious/Manifest
+++ b/dev-perl/Mojolicious/Manifest
@@ -1 +1,2 @@
DIST Mojolicious-7.57.tar.gz 706093 BLAKE2B 13212367fe09a437a97093668558ded1216465b25dd145ecf7e62256f05f129a434164a346bb3e928482fc041acfd68350e9e71ac088c49f679df43221917f73 SHA512 2bb830ca14cda5571a614ad74144c047dd96fafe49b530b1e6e19115c43cc3b8f4f174f549fdb8816183e42f26620fcf36b47f7c05ae592273c74c38dfaa4c0b
+DIST Mojolicious-7.60.tar.gz 708129 BLAKE2B bac0f8ac75255ed6d0597cc2d00eeca9da66e9c7548942daf50cca3d24875306a8e19934ae10b2e5b3bd727b1bb531b31a665938c32f861aacba6456fedf7779 SHA512 3e6e0ea266caf8e19546e587ce7bf4d8ef86fa0f2503ef7a1b97b2f4f4f55f9775894d1ad74dd4e84760a3c976f6b94451aa29260f9854d5cc3cefec512428a2
diff --git a/dev-perl/Mojolicious/Mojolicious-7.600.0.ebuild b/dev-perl/Mojolicious/Mojolicious-7.600.0.ebuild
new file mode 100644
index 000000000000..205989a4efdf
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-7.600.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SRI
+DIST_VERSION=7.60
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-JSON-PP-2.271.30
+ >=virtual/perl-Pod-Simple-3.90.0
+ >=virtual/perl-Time-Local-1.200.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod_coverage.t
+)