summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-06-02 09:55:47 -0400
committerBrian Evans <grknight@gentoo.org>2020-06-02 09:55:47 -0400
commit53ffa39dac7a025af3962456e8ee171aceb0e8f6 (patch)
treef87244063899164992b35c36453c3c86deb65cda /dev-php/PEAR-DB/PEAR-DB-1.10.0.ebuild
parentdev-php/PEAR-PEAR: Version bump for 1.10.12 (diff)
downloadgentoo-53ffa39dac7a025af3962456e8ee171aceb0e8f6.tar.gz
gentoo-53ffa39dac7a025af3962456e8ee171aceb0e8f6.tar.bz2
gentoo-53ffa39dac7a025af3962456e8ee171aceb0e8f6.zip
dev-php/PEAR-DB: Version bump for 1.10.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-DB/PEAR-DB-1.10.0.ebuild')
-rw-r--r--dev-php/PEAR-DB/PEAR-DB-1.10.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/PEAR-DB/PEAR-DB-1.10.0.ebuild b/dev-php/PEAR-DB/PEAR-DB-1.10.0.ebuild
new file mode 100644
index 000000000000..f30eacc52464
--- /dev/null
+++ b/dev-php/PEAR-DB/PEAR-DB-1.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DESCRIPTION="Database abstraction layer for PHP"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+DOCS=( doc/TESTERS doc/IDEAS doc/MAINTAINERS doc/STATUS )
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR, and also
+ # a working version of the cli SAPI eselected.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}