summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/PEAR-HTTP_Request2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/PEAR-HTTP_Request2')
-rw-r--r--dev-php/PEAR-HTTP_Request2/Manifest3
-rw-r--r--dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.0.0.ebuild17
-rw-r--r--dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.1.1.ebuild17
-rw-r--r--dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.2.1.ebuild17
-rw-r--r--dev-php/PEAR-HTTP_Request2/metadata.xml15
5 files changed, 69 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTTP_Request2/Manifest b/dev-php/PEAR-HTTP_Request2/Manifest
new file mode 100644
index 000000000000..aaab14523548
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Request2/Manifest
@@ -0,0 +1,3 @@
+DIST HTTP_Request2-2.0.0.tgz 97476 SHA256 39697e6059db1f1fcf8f45bbd9cf157e9f7e037565a235c2f1a28c9875af14bf SHA512 e77010002741e5dde07d84f03ac05b65c77812bdee624e464e7e787b2b706b20fae50fe145ea268b62b051facbcaf00da57562cada990fd98ae71bad4e6ca9bf WHIRLPOOL feaa45c75ab38c015b9f554363f994a02e320304518a047ccc2fa4a62cc12603d3439a282915c1d5db2b9b1b896e1a156d88a6164d6dfb963a01cbb559d647fa
+DIST HTTP_Request2-2.1.1.tgz 99151 SHA256 6f809dcdf3912847d43068791a0565b9e69f2bf41200aa23aad436498c665918 SHA512 b01f4dfbad090e26fb0457f9ffdb857c804b15aa25a94296b064b2cc25dc7878dfd99788dc0fc161bb53cb4c506e3f9db13cdbf307edd41d8cb91db63910bb47 WHIRLPOOL 5b8dfbf7f55a05bad79cf78646656c9a2badc7434340adf133032b360d7c05d789e1ab9ddf2aeb1dbbb885cbb99345956769d62033f148bba10cc7540051dee1
+DIST HTTP_Request2-2.2.1.tgz 107339 SHA256 1cb082560db3344a1189cd33a354091bd55ad1944a5c9152a2573b031d960704 SHA512 377421f521184b3dc4f28b1d37a1f673ee2b40b8786e39c3803ed6c60f57a2aa8353018ea588598b7ef23a1345227a41481519932998dd01958df623d00dcd82 WHIRLPOOL c70f8f159546f2fc0464ce4a199aa9ad14555a77ed2bf7a0ec0f9110b824fc72c0c4267e20dab021ee10489ba476b011ff6a64c5276535514d6b7f675f67787c
diff --git a/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.0.0.ebuild b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.0.0.ebuild
new file mode 100644
index 000000000000..31f8df8c433e
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.0.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit php-pear-r1
+
+DESCRIPTION="Provides an easy way to perform HTTP requests"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~ppc ~ppc64 ~s390 ~sh sparc x86"
+IUSE="+curl +fileinfo +ssl +zlib"
+
+RDEPEND="dev-lang/php[curl?,fileinfo?,ssl?,zlib?]
+>=dev-php/PEAR-Net_URL2-0.3.0"
diff --git a/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.1.1.ebuild b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.1.1.ebuild
new file mode 100644
index 000000000000..70b4532c9eca
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.1.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit php-pear-r1
+
+DESCRIPTION="Provides an easy way to perform HTTP requests"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+curl +fileinfo +ssl +zlib"
+
+RDEPEND="dev-lang/php[curl?,fileinfo?,ssl?,zlib?]
+>=dev-php/PEAR-Net_URL2-0.3.0"
diff --git a/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.2.1.ebuild b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.2.1.ebuild
new file mode 100644
index 000000000000..3537d7c00860
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.2.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit php-pear-r1
+
+DESCRIPTION="Provides an easy way to perform HTTP requests"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~ppc ~ppc64 ~s390 ~sh sparc x86"
+IUSE="+curl +fileinfo +ssl +zlib"
+
+RDEPEND="dev-lang/php[curl?,fileinfo?,ssl?,zlib?]
+>=dev-php/PEAR-Net_URL2-2.0.0"
diff --git a/dev-php/PEAR-HTTP_Request2/metadata.xml b/dev-php/PEAR-HTTP_Request2/metadata.xml
new file mode 100644
index 000000000000..a685ca019fad
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Request2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <longdescription lang="en">PHP5 rewrite of HTTP_Request package.
+ Provides an easy way to perform HTTP requests.
+ </longdescription>
+ <use>
+ <flag name='curl'>Force dev-lang/php to be compiled with curl extension</flag>
+ <flag name='fileinfo'>Force dev-lang/php to be compiled with fileinfo extension</flag>
+ <flag name='ssl'>Force dev-lang/php to be compiled with ssl extension</flag>
+ <flag name='zlib'>Force dev-lang/php to be compiled with zlib extension</flag>
+ </use>
+</pkgmetadata>
+