summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-06 18:30:31 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-06 18:32:35 -0500
commitd37ea2e6e234c812cec5cb46bb98adf739004fef (patch)
tree95a46452d9d7e923b1955ecb967ab25df833675b /dev-php/PEAR-Log
parentdev-php/PEAR-Log: remove unused version 1.12.8. (diff)
downloadgentoo-d37ea2e6e234c812cec5cb46bb98adf739004fef.tar.gz
gentoo-d37ea2e6e234c812cec5cb46bb98adf739004fef.tar.bz2
gentoo-d37ea2e6e234c812cec5cb46bb98adf739004fef.zip
dev-php/PEAR-Log: new version 1.13.1 replacing version 1.13.0.
This new version drops the php-pear-r1 eclass, and fixes a few bugs. The documentation is now installed in the correct location, and the examples are behind a USE flag. The "minimal" USE flag is gone, because detection of features is automagic, and we don't want to surpise users when they suddenly disappear. The test suite now also works. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/PEAR-Log')
-rw-r--r--dev-php/PEAR-Log/Manifest2
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.13.0.ebuild17
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild48
3 files changed, 49 insertions, 18 deletions
diff --git a/dev-php/PEAR-Log/Manifest b/dev-php/PEAR-Log/Manifest
index 048a8a975728..d5fd8f0f8906 100644
--- a/dev-php/PEAR-Log/Manifest
+++ b/dev-php/PEAR-Log/Manifest
@@ -1,2 +1,2 @@
DIST Log-1.12.7.tgz 46898 SHA256 7db9d8dae364e3cde16de2087a371eb862479f33d32631db947620b20d2306c0 SHA512 1c1bed9bb73a729ff8a48ed1ae0aca63384c6a14217a0aca6f9be886c1b477a07bc38a3a169e1c32430efb1b63c265fd705929e4ee5e18444f8c518a13997fc7 WHIRLPOOL d5011b48f3b1880764b2d3b1f1deeec5cf061f3e75639ab7e790e87f8551bb0b36d3ed63f33f1483314dd056e2280f8690ee92290ef11ca3f2e9d2de3cf85e7e
-DIST Log-1.13.0.tgz 46718 SHA256 9ad581d0be9b249c0066db393d936dd861925ced7e635064fee1ccdf2c6fa109 SHA512 be80bb0c15b594e178ec7cc871c6e84c7d32398843167e67699e55d3ab1fcf0ae86baa84100c8f3115da01da343c91614744245f95320dc499b85f4c6646a81c WHIRLPOOL ae809147f4b1ce35f2e0b20b84cf133e8443aaee1ad83b8880ce4ff61d77d9fc93f473b3fb9fd85cac028ccbd8c1a6d83ce26ed6d8a9c475b648109228c0857d
+DIST Log-1.13.1.tgz 46764 SHA256 2206a34816dc6b800bdfeef1dbe4ee340067c6b12b035d19db777be9325765e0 SHA512 246510b7dbff4dc9f9cdd951d76baf2dd377e30ffde6d38cadac10091dcb92f8095406edb6d8a87ebe2330d514ce99f355f84ebfe57cd8a3f3babc316995148a WHIRLPOOL fe5ed54ca52e8e1fcad406067200c556ec8bfadf7c66eec352bd0d1af5637fecec06ee00c62c06afefaa0b8207f128b163af97ef07abd25b8c67799d67044158
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.13.0.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.13.0.ebuild
deleted file mode 100644
index 254e2408114e..000000000000
--- a/dev-php/PEAR-Log/PEAR-Log-1.13.0.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-inherit php-pear-r1
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-DESCRIPTION="The Log framework provides an abstracted logging system"
-LICENSE="MIT"
-SLOT="0"
-IUSE="minimal"
-
-RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
- dev-php/PEAR-Mail
- >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild
new file mode 100644
index 000000000000..cfb9386cc9e2
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Log framework provides an abstracted logging system"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples test"
+
+# The DB, Mail, and MDB2 dependencies are technically optional, but
+# automagic. To avoid surprises, we require them unconditionally.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-DB
+ dev-php/PEAR-Mail
+ dev-php/PEAR-MDB2"
+DEPEND="test? ( ${RDEPEND} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc docs/guide.txt misc/log.sql
+ use examples && dodoc -r examples
+
+ # I don't like installing "Log.php" right at the top-level, but any
+ # packages depending on us will expect to find it there and not as
+ # e.g. Log/Log.php.
+ insinto "/usr/share/php/"
+ doins Log.php
+ doins -r Log
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}