summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-19 16:56:02 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-19 16:56:02 -0500
commit8fdd771564e15a76eb2139c8619de00726c5bb66 (patch)
tree4c71e98c285fc48ef307e25cb9e2eabb39c454da /dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r2.ebuild
parentdev-php/PEAR-Mail_Mime: Revbump to fix test dependency (diff)
downloadgentoo-8fdd771564e15a76eb2139c8619de00726c5bb66.tar.gz
gentoo-8fdd771564e15a76eb2139c8619de00726c5bb66.tar.bz2
gentoo-8fdd771564e15a76eb2139c8619de00726c5bb66.zip
dev-php/PEAR-Mail_mimeDecode: Revbump to enable tests
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r2.ebuild')
-rw-r--r--dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r2.ebuild b/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r2.ebuild
new file mode 100644
index 000000000000..adf9177c8b57
--- /dev/null
+++ b/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Provides a class to decode mime messages (split from PEAR-Mail_Mime)"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-php/PEAR-Mail_Mime-1.5.2"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+
+src_test() {
+ pear run-tests tests || die
+}