summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-08 14:44:50 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-08 14:45:13 -0400
commit4cb2d935fc113150329d82ad1c1ca9ffb7d0a4b6 (patch)
treed474471e776ea28986f3fa8895363b2499679efd /dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild
parentgnome-base/gnome-light-3.22.2: amd64 stable (diff)
downloadgentoo-4cb2d935fc113150329d82ad1c1ca9ffb7d0a4b6.tar.gz
gentoo-4cb2d935fc113150329d82ad1c1ca9ffb7d0a4b6.tar.bz2
gentoo-4cb2d935fc113150329d82ad1c1ca9ffb7d0a4b6.zip
dev-php/PEAR-Math_BigInteger: new revision sans PEAR dependency.
Gentoo-Bug: 614892 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild')
-rw-r--r--dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild b/dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..5aad8825179c
--- /dev/null
+++ b/dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pure-PHP arbitrary precision integer arithmetic library"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}
+ http://phpseclib.sourceforge.net/documentation/math.html"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Math
+
+ dodoc demo/{benchmark,demo}.php
+}