summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/PEAR-Net_IMAP
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/PEAR-Net_IMAP')
-rw-r--r--dev-php/PEAR-Net_IMAP/Manifest2
-rw-r--r--dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.1.ebuild16
-rw-r--r--dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.3.ebuild16
-rw-r--r--dev-php/PEAR-Net_IMAP/metadata.xml5
4 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_IMAP/Manifest b/dev-php/PEAR-Net_IMAP/Manifest
new file mode 100644
index 000000000000..9a4592eb2385
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/Manifest
@@ -0,0 +1,2 @@
+DIST Net_IMAP-1.1.1.tgz 37891 SHA256 168328c83116ba2d6891e54cf2b8de55a18f7d1a8831fa6e8ac5f6ef9cc2b5fd SHA512 24ac79b9d9df759883c065dde1073ffa4fc76b2cb64542c488564e24f8abd714ede01be9a1d8debd043bac93c92c37f83f5722e9cb8e2917bb89f925d8b0ac22 WHIRLPOOL 55c355274f41792a96a1ea6a09db0f59072184c402fbdea3c32a091db81d29700f4465c5a3d231a80373859dc4c96cdba1d7c10f9c1800a3ddd44268ee35dcdf
+DIST Net_IMAP-1.1.3.tgz 40494 SHA256 1ffde2d65d9e3e1a7d381fc9ee8ebac70ccfeb6ac746164423e926211b0b4487 SHA512 2eaaaa936e3656847a6702eae8e2bb2a2bbc035460dd91964323a3979eddf40d4ff340d1bca6a74712c9131e3495c49dd2bac6d3dd9b7845e7dbb20a32663283 WHIRLPOOL 583653094dd8910ed31ff48a005165e24f7ea8aadd2ab81377c6ec9483f90a5050b7e810467f51e7521aed896916e77037e29b5716f831a5cb353a6153a58547
diff --git a/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.1.ebuild b/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.1.ebuild
new file mode 100644
index 000000000000..c50c6fde796d
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit php-pear-r1
+
+DESCRIPTION="Provides an implementation of the IMAP protocol"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="sasl"
+RDEPEND=">=dev-php/PEAR-Net_Socket-1.0.8
+ !sasl? ( >=dev-php/PEAR-Auth_SASL-1.0.2 )"
diff --git a/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.3.ebuild b/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.3.ebuild
new file mode 100644
index 000000000000..eea812940db9
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.3.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit php-pear-r1
+
+DESCRIPTION="Provides an implementation of the IMAP protocol"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="sasl"
+RDEPEND=">=dev-php/PEAR-Net_Socket-1.0.8
+ sasl? ( >=dev-php/PEAR-Auth_SASL-1.0.2 )"
diff --git a/dev-php/PEAR-Net_IMAP/metadata.xml b/dev-php/PEAR-Net_IMAP/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>