summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-03-12 10:57:58 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-03-12 10:57:58 -0400
commit627066c34f95472f2c561b5145f9e1ef6a476f30 (patch)
tree59e7bee5f85b5e3f94b0262e3df42c645077f2d3 /dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild
parentapp-misc/timew: Add new package (diff)
downloadgentoo-627066c34f95472f2c561b5145f9e1ef6a476f30.tar.gz
gentoo-627066c34f95472f2c561b5145f9e1ef6a476f30.tar.bz2
gentoo-627066c34f95472f2c561b5145f9e1ef6a476f30.zip
dev-php/PEAR-Net_SMTP: new version 1.7.3.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild')
-rw-r--r--dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild
new file mode 100644
index 000000000000..cf8c9391e1a8
--- /dev/null
+++ b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A PHP implementation of the SMTP protocol"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples sasl"
+DEPEND=""
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Net_Socket
+ dev-php/PEAR-PEAR
+ sasl? ( dev-php/PEAR-Auth_SASL )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc docs/guide.txt
+ use examples && dodoc -r examples
+
+ insinto /usr/share/php
+ doins -r Net
+}