summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-14 13:28:10 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-14 13:53:41 -0500
commite3d639fcef6946b1c57126c77f6894f9d43a2dc0 (patch)
tree688eb15991e4412626b15519b3adcd5c1b057178 /dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild
parentwww-client/vivaldi-snapshot: Old. (diff)
downloadgentoo-e3d639fcef6946b1c57126c77f6894f9d43a2dc0.tar.gz
gentoo-e3d639fcef6946b1c57126c77f6894f9d43a2dc0.tar.bz2
gentoo-e3d639fcef6946b1c57126c77f6894f9d43a2dc0.zip
dev-php/PEAR-Text_Wiki: Add upstream patches direct to stable
The released version no longer works with modern PHP. This snapshot allows the package to continue. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild')
-rw-r--r--dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild b/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild
new file mode 100644
index 000000000000..cf72e330dc7e
--- /dev/null
+++ b/dev-php/PEAR-Text_Wiki/PEAR-Text_Wiki-1.2.2_p20170904.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="Abstracts parsing and rendering rules for Wiki markup in structured plain text"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="test"
+# Pull from github as pear.php.net is not updated
+SRC_URI="https://github.com/pear/${PHP_PEAR_PKG_NAME}/archive/32fd5f483f34645f4efd96d385d8950ea26d4a2a.tar.gz -> ${PEAR_P}.tar.gz"
+
+DEPEND="test? ( dev-php/phpunit dev-php/PEAR-PEAR )"
+
+src_test() {
+ peardev run-tests tests || die
+ phpunit tests/*.php || die
+}
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/.packagexml
+ newins package.xml "${PEAR_P}.xml"
+}