summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-13 18:48:52 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-13 21:01:58 +0100
commit7c9e139f4a98e8bc84d5ec8b3777149e458a2255 (patch)
treebc8cf154172ccc51ef92366d7e089e5af05153d5 /dev-php/PEAR-XML_Util
parentsys-cluster/ceph: Update boost-sonames patch for 12.2.11 (diff)
downloadgentoo-7c9e139f4a98e8bc84d5ec8b3777149e458a2255.tar.gz
gentoo-7c9e139f4a98e8bc84d5ec8b3777149e458a2255.tar.bz2
gentoo-7c9e139f4a98e8bc84d5ec8b3777149e458a2255.zip
dev-php/PEAR-XML_Util: bump to v1.4.3
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-XML_Util')
-rw-r--r--dev-php/PEAR-XML_Util/Manifest1
-rw-r--r--dev-php/PEAR-XML_Util/PEAR-XML_Util-1.4.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/PEAR-XML_Util/Manifest b/dev-php/PEAR-XML_Util/Manifest
index 23c391fb8102..d57a3c4f2f17 100644
--- a/dev-php/PEAR-XML_Util/Manifest
+++ b/dev-php/PEAR-XML_Util/Manifest
@@ -1 +1,2 @@
DIST XML_Util-1.4.2.tgz 18993 BLAKE2B b2667aed3b3ec75dd8fca1625c6fa3d03a7662c24ce0fce69cb983f42fc3f45bc0bf27bdee7353c1d29fe0eabc181f2cbd415883575f5d6cf7163097c10f6d9c SHA512 e0a328f92cdcd09277238e14d68b73cba319ab9b4e9c50ab102b43f73c889599f5933415dc228bd1feb56a48c1527e0e9a86999ee2209b2d84131691aee74cbe
+DIST XML_Util-1.4.3.tgz 18842 BLAKE2B 1cd0065b84e07a8cbc7f4d44c10362d40e71254b4964b3aa3d4d11cad5cb7e5bce780f926c69cc4fc871ac3c28d8239a428c145389950b4d6f6e626b6215dfc9 SHA512 c21a7cef90743e124c4bc8e0453b634de8f6a6b0aac060acc1a17f481a2eb8757d322b05c69151280b7651cea927b2c64b7d49b9fd815dcdc606d0472d967310
diff --git a/dev-php/PEAR-XML_Util/PEAR-XML_Util-1.4.3.ebuild b/dev-php/PEAR-XML_Util/PEAR-XML_Util-1.4.3.ebuild
new file mode 100644
index 000000000000..486a208666c5
--- /dev/null
+++ b/dev-php/PEAR-XML_Util/PEAR-XML_Util-1.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XML utility class"
+HOMEPAGE="https://pear.php.net/package/${MY_PN}"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples"
+
+# PCRE is needed for a few calls to preg_replace and preg_match.
+RDEPEND="dev-lang/php:*[pcre(+)]"
+PDEPEND="dev-php/PEAR-PEAR"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r XML
+
+ use examples && dodoc -r examples
+}