summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/ZendFramework
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/ZendFramework')
-rw-r--r--dev-php/ZendFramework/Manifest4
-rw-r--r--dev-php/ZendFramework/ZendFramework-1.12.9.ebuild74
-rw-r--r--dev-php/ZendFramework/metadata.xml15
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-php/ZendFramework/Manifest b/dev-php/ZendFramework/Manifest
new file mode 100644
index 000000000000..729c2d315362
--- /dev/null
+++ b/dev-php/ZendFramework/Manifest
@@ -0,0 +1,4 @@
+DIST ZendFramework-1.12.9-apidoc.tar.gz 11296608 SHA256 4f17292a143df6662127374abdddd1b921abbddd90422d2355606f23fc5c897c SHA512 cd14207e0f5a2091c20ab5b27c9fa63af3313756d60af98eaf17dbf4546909055560cc969d8358e4c84781c02c82ff30009c3cbe589fa5ad798cb21522fe896f WHIRLPOOL a36ce05b868c44bc1faa70b3bea68a62eb659523dccc4c7a763d4eb63d5b4aa257f7d2c728e1f628ad688cd761cf103f39f78562fdd75ff7190e0bcead179edf
+DIST ZendFramework-1.12.9-manual-en.tar.gz 3475776 SHA256 ceea2d668ccafce6e053b5ccbe45abc830280f6ab6af36d12e383dd42642c549 SHA512 58a8e3496d75c9757988854ab767bb86314e95a1eac9c02d61123ee8aeacf4f26815bf277d2c73c47b39b6ed242627ddc3125f6652f9219f7ded61cff5913407 WHIRLPOOL b445df9382e786064219e890c6fc01e22c8e8f3767f617b4f79bdf0707fc4d6f70867b820a43d76d800b625d6b159b3a3f7348cc0ef805de86b7ab2cbf0b8171
+DIST ZendFramework-1.12.9-minimal.tar.gz 8451777 SHA256 c0b353a797db77c0f52ac06f5f39b1b0ea43f98166a645c0dc75454e0be97b29 SHA512 5cc80773a6d2a9a0c9403c97c13ebec5fa3f119e5dd52a619ecfc967237e03ea0c919f35fb4c5594f9f001468161fd2d1d9dcefaa858713e8a0d6f3d99c2f338 WHIRLPOOL 125e30118c1f940137dea1e351757d5e70de1ab83a6ed09ced3f4fb0369c4a4d44304d15333acd28bcfbb229b1682aa6e4d538b09212c50a44a7721082411d4e
+DIST ZendFramework-1.12.9.tar.gz 27343626 SHA256 ba9dbcc0de424876ffd5bf6293522f68677fcea862546ee1fc9219bcff2bf690 SHA512 591fd92b80fcbae5dfbd3b2aa3678ae7c307b20cb62f91d1f45df821bf2d0876d0d006a0077dd217fe192914608a816afbe09f90f4fa991d97a64558d76be389 WHIRLPOOL 5460db9a52106d09c30999ccabe983a55c19584162d527569c70faf3cf1466bc44e8206ab068519cc8b655fca435693bab73d9debdcd7e8cd1de34a938512a84
diff --git a/dev-php/ZendFramework/ZendFramework-1.12.9.ebuild b/dev-php/ZendFramework/ZendFramework-1.12.9.ebuild
new file mode 100644
index 000000000000..d4b445b60344
--- /dev/null
+++ b/dev-php/ZendFramework/ZendFramework-1.12.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="amd64 hppa ~ppc x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications"
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="!minimal? ( http://framework.zend.com/releases/${P}/${P}.tar.gz )
+ minimal? ( http://framework.zend.com/releases/${P}/${P}-minimal.tar.gz )
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="cli doc examples minimal"
+
+DEPEND="cli? ( dev-lang/php:*[simplexml,tokenizer] )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use minimal ; then
+ S="${WORKDIR}/${P}-minimal"
+ if use doc ; then
+ mv "${WORKDIR}/${P}/documentation" "${S}"
+ fi
+ fi
+}
+
+src_install() {
+ if use cli ; then
+ insinto /usr/bin
+ doins bin/zf.php
+ dobin bin/zf.sh
+ dosym /usr/bin/zf.sh /usr/bin/zf
+ fi
+ php-lib-r1_src_install library/Zend $(cd library/Zend ; find . -type f -print)
+
+ if ! use minimal ; then
+ insinto /usr/share/php
+ doins -r externals/dojo
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos
+ fi
+ fi
+
+ dodoc README.md
+ if use doc ; then
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ elog "For more info, please take a look at the manual at:"
+ elog "http://framework.zend.com/manual"
+ elog ""
+
+ if use minimal; then
+ elog "You have installed the minimal version of ZendFramework,"
+ elog "so the Dojo toolkit, demos and tests have not been installed."
+ else
+ elog "You have installed the full version of ZendFramework, which"
+ elog "includes the Dojo toolkit, demos and tests."
+ elog "To install ZendFramework without these, enable the"
+ elog "minimal USE flag."
+ fi
+}
diff --git a/dev-php/ZendFramework/metadata.xml b/dev-php/ZendFramework/metadata.xml
new file mode 100644
index 000000000000..d240bb4ffcea
--- /dev/null
+++ b/dev-php/ZendFramework/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <maintainer>
+ <email>gurligebis@gentoo.org</email>
+ <name>Bjarke Istrup Pedersen</name>
+ </maintainer>
+ <use>
+ <flag name='cli'>Enables the CLI</flag>
+ <flag name='doc'>Installs the documentation</flag>
+ <flag name='examples'>Installs the examples</flag>
+ <flag name='minimal'>Installs the minimal version without Dojo toolkit, tests and demos</flag>
+ </use>
+</pkgmetadata>