summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/awl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/awl')
-rw-r--r--dev-php/awl/Manifest2
-rw-r--r--dev-php/awl/awl-0.53-r2.ebuild30
-rw-r--r--dev-php/awl/awl-0.55-r1.ebuild33
-rw-r--r--dev-php/awl/metadata.xml9
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-php/awl/Manifest b/dev-php/awl/Manifest
new file mode 100644
index 000000000000..35f3a5696050
--- /dev/null
+++ b/dev-php/awl/Manifest
@@ -0,0 +1,2 @@
+DIST awl-0.53.tar.gz 308256 SHA256 8b012f6df172c70af2eb7f9f860b391429b3a261499c904d906532c34aee59ee SHA512 70bcfc9d52a46245a11fbe787e4818d183d6cbcad50f21ad821c1cc6fb9d58664231693d11b61db644f5fd50d77fea5e4491e16573d59427e89555ed21f8c72b WHIRLPOOL 76a4e745082dc16182a0b214653f6c691f913870056d47f75911aaffc5bb5a6f96deb65d850fd6d37b727cdda63680f48c1f1b88bf1165bca4c8d6c0c17f7bcf
+DIST awl-0.55.tar.gz 765565 SHA256 69d8f51e8aefdfb6b5a0fc3e5e32f8b8d650c489079c8ebac5a6b65f2ad3ec89 SHA512 f4b0b81449bb244b27308022aed3f9b9093535bd9e76db2d13a8bf146f65eadc2b1d2a53f1d8e275b8c693301d371f2ddb2fa696b484368541dad51d893c4757 WHIRLPOOL dc0937651c4fd2304d2789b57fcf738c48a61b51ccd5cee57129a4e4cd454e83e4aec46287ab0ac0bdf98a6a7ad8e7bbb98cd32deb633a63d1f2ae54c91c4fb7
diff --git a/dev-php/awl/awl-0.53-r2.ebuild b/dev-php/awl/awl-0.53-r2.ebuild
new file mode 100644
index 000000000000..1c37fbe63af1
--- /dev/null
+++ b/dev-php/awl/awl-0.53-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Andrew McMillan's web libraries: A collection of generic classes
+used by the davical calendar server"
+HOMEPAGE="http://andrew.mcmillan.net.nz/projects/awl"
+SRC_URI="http://debian.mcmillan.net.nz/packages/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-lang/php:*[pdo,postgres,xml]"
+
+DOCS=( debian/README.Debian debian/changelog )
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodoc "${DOCS[@]}"
+ use doc && dohtml -r "docs/api/"
+ insinto "/usr/share/php/${PN}"
+ doins -r dba inc scripts
+}
diff --git a/dev-php/awl/awl-0.55-r1.ebuild b/dev-php/awl/awl-0.55-r1.ebuild
new file mode 100644
index 000000000000..eb2c5ae25044
--- /dev/null
+++ b/dev-php/awl/awl-0.55-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Andrew McMillan's Web Libraries"
+HOMEPAGE="https://gitlab.com/davical-project/awl"
+SRC_URI="${HOMEPAGE}/repository/archive.tar.gz?ref=r${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php:*[pdo,postgres,xml]"
+S="${WORKDIR}/${PN}.git"
+
+src_compile() {
+ :
+}
+
+src_test() {
+ phpunit tests/ || die "test suite failed"
+}
+
+src_install() {
+ dodoc debian/changelog
+ use doc && dohtml -r "docs/api/"
+ insinto "/usr/share/php/${PN}"
+ doins -r dba inc
+}
diff --git a/dev-php/awl/metadata.xml b/dev-php/awl/metadata.xml
new file mode 100644
index 000000000000..0bb482da5813
--- /dev/null
+++ b/dev-php/awl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>