summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-12-18 16:50:02 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-12-18 18:17:19 -0500
commitfb900d1dc0634fb7c6ce5c80ee9d84d8864a11db (patch)
tree35312e7cd17dec3c85dcf9002fa685b0a0190b56 /dev-php/composer/composer-1.2.2-r1.ebuild
parentdev-php/composer: add upstream/remote-id tag to metadata.xml. (diff)
downloadgentoo-fb900d1dc0634fb7c6ce5c80ee9d84d8864a11db.tar.gz
gentoo-fb900d1dc0634fb7c6ce5c80ee9d84d8864a11db.tar.bz2
gentoo-fb900d1dc0634fb7c6ce5c80ee9d84d8864a11db.zip
dev-php/composer: loosen restrictions on dependencies.
Many of this package's dependencies were declared with the tilde "~" operator. Per discussion with the maintainer, these are probably better off being "newer than" operators. We retain the lower bound set by upstream. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/composer/composer-1.2.2-r1.ebuild')
-rw-r--r--dev-php/composer/composer-1.2.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/composer/composer-1.2.2-r1.ebuild b/dev-php/composer/composer-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..a5e2f00d6146
--- /dev/null
+++ b/dev-php/composer/composer-1.2.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*[curl]
+ >=dev-php/ca-bundle-1.0.0
+ >=dev-php/cli-prompt-1.0.0
+ >=dev-php/psr-log-1.0.2
+ dev-php/fedora-autoloader
+ >=dev-php/json-schema-2.0.0
+ >=dev-php/jsonlint-1.4.0
+ >=dev-php/phar-utils-1.0.0
+ >=dev-php/semver-1.0.0
+ >=dev-php/spdx-licenses-1.0.0
+ >=dev-php/symfony-console-2.7.9
+ >=dev-php/symfony-filesystem-2.7.20
+ >=dev-php/symfony-finder-2.7.20
+ >=dev-php/symfony-process-2.8.12"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-update-paths.patch"
+)
+
+src_install() {
+ insinto "/usr/share/php/Composer/Composer"
+ doins -r src/Composer/. res LICENSE "${FILESDIR}"/autoload.php
+ dobin bin/composer
+ dodoc README.md
+}