summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2017-12-03 13:38:55 +0100
committerMichael Orlitzky <mjo@gentoo.org>2017-12-03 10:04:35 -0500
commit9fc1f071d62c5cc024406a5cc6d336a6f5f6b955 (patch)
tree93a72caa57b0e5fc75e4afbed6a02969b2eb320b /dev-php/composer/composer-1.5.5.ebuild
parentnet-mail/mu: Disable optional GUI support as it requires an obsolete and vuln... (diff)
downloadgentoo-9fc1f071d62c5cc024406a5cc6d336a6f5f6b955.tar.gz
gentoo-9fc1f071d62c5cc024406a5cc6d336a6f5f6b955.tar.bz2
gentoo-9fc1f071d62c5cc024406a5cc6d336a6f5f6b955.zip
dev-php/composer: Add version bump 1.5.5
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://bugs.gentoo.org/639504 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/composer/composer-1.5.5.ebuild')
-rw-r--r--dev-php/composer/composer-1.5.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-php/composer/composer-1.5.5.ebuild b/dev-php/composer/composer-1.5.5.ebuild
new file mode 100644
index 000000000000..7e9f959246d2
--- /dev/null
+++ b/dev-php/composer/composer-1.5.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*[curl]
+ >=dev-php/ca-bundle-1.0.0
+ >=dev-php/cli-prompt-1.0.0
+ >=dev-php/psr-log-1.0.2
+ dev-php/fedora-autoloader
+ >=dev-php/json-schema-3.0.0
+ >=dev-php/jsonlint-1.4.0
+ >=dev-php/phar-utils-1.0.0
+ >=dev-php/semver-1.0.0
+ >=dev-php/spdx-licenses-1.0.0
+ >=dev-php/symfony-console-2.7.9
+ >=dev-php/symfony-filesystem-2.7.20
+ >=dev-php/symfony-finder-2.7.20
+ >=dev-php/symfony-process-2.8.12"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+
+ # Composer expects the LICENSE file to be there, and the
+ # easiest thing to do is to give it what it wants.
+ doins -r src res LICENSE
+
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}"/autoload.php
+
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ dosym "/usr/share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ dodoc CHANGELOG.md README.md doc/*.md
+ dodoc -r doc/articles doc/faqs
+}