summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-17 21:43:29 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-17 22:01:26 +0100
commit481f0aa8b4b2c477e5e76b26daeda094f3212e3f (patch)
treeefe236bb0d692a7ad1e198c40faa7a7e7d6a395b /dev-php/json-schema
parentdev-php/pecl-http: bump to v3.2.3 (diff)
downloadgentoo-481f0aa8b4b2c477e5e76b26daeda094f3212e3f.tar.gz
gentoo-481f0aa8b4b2c477e5e76b26daeda094f3212e3f.tar.bz2
gentoo-481f0aa8b4b2c477e5e76b26daeda094f3212e3f.zip
dev-php/json-schema: bump to v5.2.9
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/json-schema')
-rw-r--r--dev-php/json-schema/Manifest1
-rw-r--r--dev-php/json-schema/json-schema-5.2.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/json-schema/Manifest b/dev-php/json-schema/Manifest
index 50eaebbc2f83..c12287c45374 100644
--- a/dev-php/json-schema/Manifest
+++ b/dev-php/json-schema/Manifest
@@ -1 +1,2 @@
DIST json-schema-5.2.8.tar.gz 31179 BLAKE2B fc422b4ea632299308fe44104ed66365441879441446d47bad1da89182da0c1aba04877c279577fe7e8fc9f82e4677bc755558a4f4fa1893362d2b93e8743a08 SHA512 04a96413a12979ee42cc72dc7d6cd73ab26472c46cffa1ce65d7e2338867ec6cce48da5a058d4c8bb849a8fae72376272b814f3a808ed3374af9c98eb8674fe5
+DIST json-schema-5.2.9.tar.gz 31336 BLAKE2B 42d1a36810a28050bc543a4d79a3701444e86176e3c514ac198c7b6e8300edc615652c0116e44977c2bbbcaad17da96a4d32642cb304b653efe417e6a5aa67d3 SHA512 4666df39ad50a284687c216b30ac50a5ef4019260fbe0ecb052c820f9c029a904c07fae7606df3ab24b1ac18f651ca4a93ee83847e76361fd41072ce04ded222
diff --git a/dev-php/json-schema/json-schema-5.2.9.ebuild b/dev-php/json-schema/json-schema-5.2.9.ebuild
new file mode 100644
index 000000000000..0c8201a0dd70
--- /dev/null
+++ b/dev-php/json-schema/json-schema-5.2.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="PHP implementation of JSON schema"
+HOMEPAGE="https://github.com/justinrainbow/json-schema"
+SRC_URI="https://github.com/justinrainbow/json-schema/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# Tests are not in the release tarball
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/JsonSchema"
+ doins -r src/JsonSchema/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}