summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-03-22 13:25:42 -0400
committerBrian Evans <grknight@gentoo.org>2018-03-22 13:26:37 -0400
commit39422d51690a1d8349d0c338af9ac17eac4819bb (patch)
treeff8cfc217556df9ad107c6fa407f8431399ccc86 /dev-php/libvirt-php/libvirt-php-9999.ebuild
parentdev-libs/lzo: sh stable wrt bug #612872 (diff)
downloadgentoo-39422d51690a1d8349d0c338af9ac17eac4819bb.tar.gz
gentoo-39422d51690a1d8349d0c338af9ac17eac4819bb.tar.bz2
gentoo-39422d51690a1d8349d0c338af9ac17eac4819bb.zip
dev-php/libvirt-php: Adjust unpack and prepare wrt eclass changes
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/libvirt-php/libvirt-php-9999.ebuild')
-rw-r--r--dev-php/libvirt-php/libvirt-php-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-php/libvirt-php/libvirt-php-9999.ebuild b/dev-php/libvirt-php/libvirt-php-9999.ebuild
index 4e24b63e0ab6..2943eb7e578a 100644
--- a/dev-php/libvirt-php/libvirt-php-9999.ebuild
+++ b/dev-php/libvirt-php/libvirt-php-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,6 +6,7 @@ EAPI=6
PHP_EXT_NAME="libvirt-php"
PHP_EXT_SKIP_PHPIZE="yes"
USE_PHP="php5-6 php7-0 php7-1"
+PHP_EXT_ECONF_ARGS=()
inherit php-ext-source-r3 git-r3 autotools
@@ -27,6 +28,9 @@ DEPEND="${RDEPEND}
RESTRICT="test"
DOCS=( ChangeLog NEWS README )
+# Remove the insane check for pecl-imagick which is only used in examples
+# and is not called upon in any build
+PATCHES=( "${FILESDIR}/remove-imagick-check.patch" )
src_unpack() {
git-r3_src_unpack
@@ -34,20 +38,13 @@ src_unpack() {
# create the default modules directory to be able
# to use the php-ext-source-r3 eclass to configure/build
ln -s src "${S}/modules"
-
- for slot in $(php_get_slots); do
- cp -r "${S}" "${WORKDIR}/${slot}"
- done
}
src_prepare() {
- # Remove the insane check for pecl-imagick which is only used in examples
- # and is not called upon in any build
+ php-ext-source-r3_src_prepare
local slot
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
- eapply "${FILESDIR}/remove-imagick-check.patch"
- eapply_user
eautoreconf
done
}