summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/libvirt-php
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/libvirt-php')
-rw-r--r--dev-php/libvirt-php/Manifest1
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.4.8.ebuild51
-rw-r--r--dev-php/libvirt-php/libvirt-php-9999.ebuild61
-rw-r--r--dev-php/libvirt-php/metadata.xml9
4 files changed, 122 insertions, 0 deletions
diff --git a/dev-php/libvirt-php/Manifest b/dev-php/libvirt-php/Manifest
new file mode 100644
index 000000000000..824a4a521b46
--- /dev/null
+++ b/dev-php/libvirt-php/Manifest
@@ -0,0 +1 @@
+DIST libvirt-php-0.4.8.tar.gz 249753 SHA256 75508ab420c45fface8cdd8328053eee2207f8ff2aab572627ba8f30aacaef35 SHA512 2c1cbe914ab73a45b917130224fd803bfb41b0cc470d5480050c6d512dc4509ee96adcaa3ce3735747f17c4748ce66782437009b5445c364800fa308ee5059d1 WHIRLPOOL bdf18892348de1a8984e23a7f3044f3f861956fd4bf28796f0a79c91079081b97fe630adf6073db2bf94534df22becc503dfb81cc0cc5f1ebf39e6804c93d905
diff --git a/dev-php/libvirt-php/libvirt-php-0.4.8.ebuild b/dev-php/libvirt-php/libvirt-php-0.4.8.ebuild
new file mode 100644
index 000000000000..18cc966194ad
--- /dev/null
+++ b/dev-php/libvirt-php/libvirt-php-0.4.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-source-r2 eutils
+
+DESCRIPTION="PHP 5 bindings for libvirt"
+HOMEPAGE="http://libvirt.org/php/"
+SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="app-emulation/libvirt
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ doc? ( app-text/xhtml1 )"
+
+RESTRICT="test"
+
+src_unpack() {
+ default
+ # create the default modules directory to be able
+ # to use the php-ext-source-r2 eclass to configure/build
+ ln -s src "${S}/modules"
+
+ for slot in $(php_get_slots); do
+ cp -r "${S}" "${WORKDIR}/${slot}"
+ done
+}
+
+src_install() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ newins "src/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r2_createinifiles
+ dodoc AUTHORS ChangeLog NEWS README
+ use doc && dohtml docs/* docs/graphics/*
+}
diff --git a/dev-php/libvirt-php/libvirt-php-9999.ebuild b/dev-php/libvirt-php/libvirt-php-9999.ebuild
new file mode 100644
index 000000000000..f599904d1c9f
--- /dev/null
+++ b/dev-php/libvirt-php/libvirt-php-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php5-6 php5-5 php5-4"
+# Automake 1.14 is broken. Check this later
+WANT_AUTOMAKE="1.13"
+
+inherit php-ext-source-r2 git-r3 autotools
+
+DESCRIPTION="PHP 5 bindings for libvirt"
+HOMEPAGE="http://libvirt.org/php/"
+EGIT_REPO_URI="git://libvirt.org/libvirt-php.git"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+RDEPEND="app-emulation/libvirt
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ doc? ( app-text/xhtml1 )"
+
+RESTRICT="test"
+
+src_unpack() {
+ git-r3_src_unpack
+
+ # create the default modules directory to be able
+ # to use the php-ext-source-r2 eclass to configure/build
+ ln -s src "${S}/modules"
+
+ for slot in $(php_get_slots); do
+ cp -r "${S}" "${WORKDIR}/${slot}"
+ done
+}
+
+src_prepare() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ eautoreconf
+ done
+}
+
+src_install() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ newins "src/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r2_createinifiles
+ dodoc AUTHORS ChangeLog NEWS README
+ use doc && dohtml docs/* docs/graphics/*
+}
diff --git a/dev-php/libvirt-php/metadata.xml b/dev-php/libvirt-php/metadata.xml
new file mode 100644
index 000000000000..f093bc851879
--- /dev/null
+++ b/dev-php/libvirt-php/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>