summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-10-17 21:14:44 -0400
committerBrian Evans <grknight@gentoo.org>2018-10-17 21:14:44 -0400
commitb60e51f25185a1a9a25044925133eef345e10573 (patch)
tree920e74f01d2f7dd5f7d04b1215a53584141dcaf1 /dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
parentnet-im/signal-desktop-bin: bump (diff)
downloadgentoo-b60e51f25185a1a9a25044925133eef345e10573.tar.gz
gentoo-b60e51f25185a1a9a25044925133eef345e10573.tar.bz2
gentoo-b60e51f25185a1a9a25044925133eef345e10573.zip
dev-php/pecl-apcu_bc: Fix tests in 1.0.4
Closes: https://bugs.gentoo.org/667494 Signed-off-by: Brian Evans <grknight@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild')
-rw-r--r--dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild23
1 files changed, 21 insertions, 2 deletions
diff --git a/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
index 6cb699b96c74..30400a425c6b 100644
--- a/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
+++ b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ DOCS=( README.md )
USE_PHP="php7-0 php7-1 php7-2"
-inherit php-ext-pecl-r3
+inherit php-ext-pecl-r3 multilib
KEYWORDS="~amd64 ~x86"
@@ -23,3 +23,22 @@ IUSE=""
DEPEND="dev-php/pecl-apcu:7[php_targets_php7-0?,php_targets_php7-1?,php_targets_php7-2?]"
RDEPEND="${DEPEND}"
+
+src_test() {
+ # This fixed version is necessary to have apcu load
+ # from the install before the tested apc.
+ # It is intentional to specify phpoptions twice.
+ # This mimics the Makefile.
+ local slot phpoptions
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ ln -s "${EXT_DIR}/apcu$(get_libname)" \
+ "modules/" || die
+ phpoptions=( -n -d extension_dir="${PHP_EXT_S}/modules"
+ -d extension=apcu$(get_libname)
+ -d extension=apc$(get_libname) )
+ NO_INTERACTION="yes" TEST_PHP_EXECUTABLE="${PHPCLI}" \
+ "${PHPCLI}" "${phpoptions[@]}" \
+ run-tests.php "${phpoptions[@]}" || die
+ done
+}