summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-crack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-crack')
-rw-r--r--dev-php/pecl-crack/Manifest1
-rw-r--r--dev-php/pecl-crack/files/fix-pecl-bug-5765.patch11
-rw-r--r--dev-php/pecl-crack/files/fix-php-5-4-support.patch30
-rw-r--r--dev-php/pecl-crack/metadata.xml5
-rw-r--r--dev-php/pecl-crack/pecl-crack-0.4-r4.ebuild32
5 files changed, 79 insertions, 0 deletions
diff --git a/dev-php/pecl-crack/Manifest b/dev-php/pecl-crack/Manifest
new file mode 100644
index 000000000000..eb6e3a225f11
--- /dev/null
+++ b/dev-php/pecl-crack/Manifest
@@ -0,0 +1 @@
+DIST crack-0.4.tgz 25524 SHA256 00a5250a6c82b39c1aefcb6e1ce0980da5df49c9bfc6ade9a8e867d89e87f560 SHA512 0dec64d1ce859bb3d7e2b834e4bcc4ef8c6f3e88e5b61884e40dddc366a992a7c85bfad4227224d4401aad7f26843678709f29acd2dcc75563658040b8067d7f WHIRLPOOL 2b6d26cf65912f6fac72733711ed48e0c859df28a3c7a2b351e607edcc51f15fea7cfef01419b3fd56267ddf9c57f4a75f93e64015c0db9d14e5799ac1a411c7
diff --git a/dev-php/pecl-crack/files/fix-pecl-bug-5765.patch b/dev-php/pecl-crack/files/fix-pecl-bug-5765.patch
new file mode 100644
index 000000000000..c180d5310b1b
--- /dev/null
+++ b/dev-php/pecl-crack/files/fix-pecl-bug-5765.patch
@@ -0,0 +1,11 @@
+--- crack-0.4/libcrack/src/cracklib.h 2005-09-21 11:00:06.000000000 +0200
++++ crack-0.4-new/libcrack/src/cracklib.h 2006-10-08 20:44:00.618783250 +0200
+@@ -46,7 +46,7 @@
+
+ typedef unsigned char int8;
+ typedef unsigned short int int16;
+-typedef unsigned long int int32;
++typedef unsigned int int32;
+
+ #ifndef NUMWORDS
+ # define NUMWORDS 16
diff --git a/dev-php/pecl-crack/files/fix-php-5-4-support.patch b/dev-php/pecl-crack/files/fix-php-5-4-support.patch
new file mode 100644
index 000000000000..4709ad8dd116
--- /dev/null
+++ b/dev-php/pecl-crack/files/fix-php-5-4-support.patch
@@ -0,0 +1,30 @@
+Gentoo bug: 423869
+Thanks to hanno
+
+--- pecl/crack/trunk/crack.c 2008/07/17 10:02:47 262854
++++ pecl/crack/trunk/crack.c 2012/06/07 16:13:34 326013
+@@ -38,7 +38,7 @@
+
+ /* {{{ crack_functions[]
+ */
+-function_entry crack_functions[] = {
++zend_function_entry crack_functions[] = {
+ PHP_FE(crack_opendict, NULL)
+ PHP_FE(crack_closedict, NULL)
+ PHP_FE(crack_check, NULL)
+@@ -94,6 +94,7 @@
+ int filename_len;
+ int result = SUCCESS;
+
++#if PHP_VERSION_ID < 50400
+ if (PG(safe_mode)) {
+ filename_len = strlen(path) + 10;
+ filename = (char *) emalloc(filename_len);
+@@ -125,6 +126,7 @@
+ return FAILURE;
+ }
+ }
++#endif
+
+ if (php_check_open_basedir(path TSRMLS_CC)) {
+ return FAILURE;
diff --git a/dev-php/pecl-crack/metadata.xml b/dev-php/pecl-crack/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/pecl-crack/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-crack/pecl-crack-0.4-r4.ebuild b/dev-php/pecl-crack/pecl-crack-0.4-r4.ebuild
new file mode 100644
index 000000000000..38567b04e982
--- /dev/null
+++ b/dev-php/pecl-crack/pecl-crack-0.4-r4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="crack"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="EXPERIMENTAL"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="amd64 ppc ppc64 x86"
+
+DESCRIPTION="PHP interface to the cracklib libraries"
+LICENSE="PHP-3 CRACKLIB"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ local slot
+ for slot in $(php_get_slots) ; do
+ cd "${WORKDIR}/${slot}"
+ epatch "${FILESDIR}/fix-php-5-4-support.patch"
+ # Patch for http://pecl.php.net/bugs/bug.php?id=5765
+ epatch "${FILESDIR}/fix-pecl-bug-5765.patch"
+ done
+ php-ext-source-r2_src_prepare
+}