summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-eio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-eio')
-rw-r--r--dev-php/pecl-eio/Manifest1
-rw-r--r--dev-php/pecl-eio/metadata.xml10
-rw-r--r--dev-php/pecl-eio/pecl-eio-1.2.5.ebuild27
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-php/pecl-eio/Manifest b/dev-php/pecl-eio/Manifest
new file mode 100644
index 000000000000..0853f5eaa6fc
--- /dev/null
+++ b/dev-php/pecl-eio/Manifest
@@ -0,0 +1 @@
+DIST eio-1.2.5.tgz 57539 SHA256 ee7b21aa413cbe39caaef1d2eb893fa3bcb9a278b5665c28d179a83a4a1bdb51 SHA512 629f4e0cd3f632ec7d5aed299a6f55ba089f8d455a974c02c892515212d1f9a28ee2977ef513eba8b7fddf3431449716f70c29999dcd71df77ea26baae8994d5 WHIRLPOOL 2bffa6aca39ccf85dda44b4a18f966a4be4bcf3dc0a53c2eac2443574b189540732b0204b4c8a7d1825956c7b9aa15946680d65ff16ad7237b3f535c960f10fd
diff --git a/dev-php/pecl-eio/metadata.xml b/dev-php/pecl-eio/metadata.xml
new file mode 100644
index 000000000000..b34d5e1b1c73
--- /dev/null
+++ b/dev-php/pecl-eio/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+<email>rrosmanov@gmail.com</email>
+<name>Ruslan Osmanov</name>
+<description>Maintainer. Assign bugs to him</description>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-php/pecl-eio/pecl-eio-1.2.5.ebuild b/dev-php/pecl-eio/pecl-eio-1.2.5.ebuild
new file mode 100644
index 000000000000..ba7fa0b038c1
--- /dev/null
+++ b/dev-php/pecl-eio/pecl-eio-1.2.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PHP_EXT_NAME="eio"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS EXPERIMENTAL INSTALL README LICENSE"
+
+USE_PHP="php5-4 php5-5 php5-6"
+inherit php-ext-pecl-r2 confutils
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="PHP-3.01"
+
+DESCRIPTION="PHP wrapper for libeio library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="debug"
+
+src_configure() {
+ my_conf="--with-eio"
+ enable_extension_enable "eio-debug" "debug" 0
+
+ php-ext-source-r2_src_configure
+}