summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-14 15:47:09 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-14 15:47:36 +0100
commit507e6ed891234a0078758860bfa6da1c1a067e99 (patch)
treef21de960165d3dc7a0e0664801fc00c66c5a19f3 /dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild
parentmedia-plugins/kodi-pvr-mediaportal-tvserver: 3.5.15 version bump (diff)
downloadgentoo-507e6ed891234a0078758860bfa6da1c1a067e99.tar.gz
gentoo-507e6ed891234a0078758860bfa6da1c1a067e99.tar.bz2
gentoo-507e6ed891234a0078758860bfa6da1c1a067e99.zip
dev-php/pecl-imagick: bump to snapshot version to add PHP 7.3 support
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild')
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild
new file mode 100644
index 000000000000..e1c86fc73437
--- /dev/null
+++ b/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PHP_EXT_NAME="imagick"
+
+MY_COMMIT="d57a444766a321fa226266f51f1f42ee2cc29cc7"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+
+S="${WORKDIR}/imagick-${MY_COMMIT}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library"
+HOMEPAGE="https://pecl.php.net/imagick https://github.com/mkoppanen/imagick"
+SRC_URI="https://github.com/mkoppanen/imagick/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples test"
+
+# imagemagick[-openmp] is needed wrt bug 547922 and upstream
+# https://github.com/mkoppanen/imagick#openmp
+RDEPEND=">=media-gfx/imagemagick-6.2.4:=[-openmp]"
+DEPEND="${RDEPEND}
+ test? ( >=media-gfx/imagemagick-6.2.4:=[jpeg,png,truetype] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.3-tsrm_ls-is-undeclared.patch )
+
+PHP_EXT_ECONF_ARGS="--with-imagick=${EPREFIX%/}/usr"