summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-04-05 22:12:44 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-04-05 22:21:41 +0200
commit98b74a5a3d71299055ad9f0352f9804445c84e8a (patch)
tree35e5306b3fc04f9b59794235e415503a86055515 /dev-php/pecl-mailparse/pecl-mailparse-3.0.3.ebuild
parentdev-php/igbinary: bump to v3.0.1 (diff)
downloadgentoo-98b74a5a3d71299055ad9f0352f9804445c84e8a.tar.gz
gentoo-98b74a5a3d71299055ad9f0352f9804445c84e8a.tar.bz2
gentoo-98b74a5a3d71299055ad9f0352f9804445c84e8a.zip
dev-php/pecl-mailparse: bump to v3.0.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-mailparse/pecl-mailparse-3.0.3.ebuild')
-rw-r--r--dev-php/pecl-mailparse/pecl-mailparse-3.0.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/pecl-mailparse/pecl-mailparse-3.0.3.ebuild b/dev-php/pecl-mailparse/pecl-mailparse-3.0.3.ebuild
new file mode 100644
index 000000000000..0caa08eb4a87
--- /dev/null
+++ b/dev-php/pecl-mailparse/pecl-mailparse-3.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="mailparse"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+DOCS=( README.md )
+
+USE_PHP="php7-0 php7-1 php5-6 php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+# Only build for 7.x
+USE_PHP="php7-0 php7-1 php7-2 php7-3"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for parsing and working with RFC822 and MIME compliant messages"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+
+PHPUSEDEPEND="
+ php_targets_php7-0? ( dev-lang/php:7.0[unicode] )
+ php_targets_php7-1? ( dev-lang/php:7.1[unicode] )
+ php_targets_php7-2? ( dev-lang/php:7.2[unicode] )
+"
+DEPEND="${PHPUSEDEPEND}
+ dev-util/re2c"
+RDEPEND="${PHPUSEDEPEND} php_targets_php5-6? ( dev-php/pecl-mailparse:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ # Missing test source files in archive. Fixed upstream in next release.
+ rm tests/011.phpt tests/bug001.phpt || die
+ php-ext-source-r3_src_prepare
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}