summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-01 10:45:16 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-01 10:46:54 -0500
commitc9d8584078c2d8780b1c3267d9d97d694c45cd1e (patch)
tree56815c096e28e73eb63ce67016a6308d5f5e62d3 /dev-php/pecl-oauth
parentdev-php/pecl-ncurses: Drop old (diff)
downloadgentoo-c9d8584078c2d8780b1c3267d9d97d694c45cd1e.tar.gz
gentoo-c9d8584078c2d8780b1c3267d9d97d694c45cd1e.tar.bz2
gentoo-c9d8584078c2d8780b1c3267d9d97d694c45cd1e.zip
dev-php/pecl-oauth: Revision bump to drop php 5.4 and 5.5
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/pecl-oauth')
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-1.2.3-r4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/pecl-oauth/pecl-oauth-1.2.3-r4.ebuild b/dev-php/pecl-oauth/pecl-oauth-1.2.3-r4.ebuild
new file mode 100644
index 000000000000..7d9bd3cfe502
--- /dev/null
+++ b/dev-php/pecl-oauth/pecl-oauth-1.2.3-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PHP_EXT_NAME="oauth"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[hash] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
+RDEPEND="${DEPEND}"