summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-28 16:01:08 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-28 16:19:49 -0500
commit8639a7ef6a57f2e5337d9d81f482f6fba5152589 (patch)
treeb9395d28ffb4672b2eafe6cb6cf7717ca36f6477 /dev-php/pecl-raphf/pecl-raphf-2.0.0-r1.ebuild
parentdev-perl/Time-ParseDate: ppc/ppc64/x86 ALLARCHES stable re bug #588030 (diff)
downloadgentoo-8639a7ef6a57f2e5337d9d81f482f6fba5152589.tar.gz
gentoo-8639a7ef6a57f2e5337d9d81f482f6fba5152589.tar.bz2
gentoo-8639a7ef6a57f2e5337d9d81f482f6fba5152589.zip
dev-php/pecl-raphf: Revision bumps to add php 7.1 support
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/pecl-raphf/pecl-raphf-2.0.0-r1.ebuild')
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.0-r1.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..c70af5650bf5
--- /dev/null
+++ b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PHP_EXT_NAME="raphf"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+# Only really build for 7.x
+USE_PHP="php7-0 php7-1"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A reusable, persistent handle and resource factory API"
+LICENSE="BSD-2"
+SLOT="7"
+IUSE=""
+
+RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}