summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:07:30 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:13:36 +0200
commit99a7b03f4133a1c6f8d5b68fa244762a3c41737a (patch)
tree9b1de34da6bc1d6b78f1eec664dffdb9d1480798 /dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
parentdev-php/geos-php: add PHP 7.3 support (diff)
downloadgentoo-99a7b03f4133a1c6f8d5b68fa244762a3c41737a.tar.gz
gentoo-99a7b03f4133a1c6f8d5b68fa244762a3c41737a.tar.bz2
gentoo-99a7b03f4133a1c6f8d5b68fa244762a3c41737a.zip
dev-php/pecl-ssh2: add PHP 7.3 support
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
index e493a7b71a86..72ef46fdff15 100644
--- a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
+++ b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
PHP_EXT_NAME="ssh2"
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
inherit php-ext-source-r3 git-r3
-USE_PHP="php7-0 php7-1 php7-2"
+USE_PHP="php7-1 php7-2 php7-3"
DESCRIPTION="PHP bindings for the libssh2 library"
LICENSE="PHP-3.01"
@@ -23,7 +23,7 @@ RDEPEND="${DEPEND}
HOMEPAGE="https://pecl.php.net/package/ssh2"
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare