summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-07-25 11:32:17 -0400
committerBrian Evans <grknight@gentoo.org>2016-07-25 11:32:17 -0400
commita9d766d6acb7ddf76b71a91e157a3b0c48593523 (patch)
tree53235915a6c86d8a6f14e678cee8b47d48f96b35 /dev-php/pecl-yaml/pecl-yaml-1.3.0_beta1.ebuild
parentapp-text/paps: Fix bad handling of empty files (bug 566050). (diff)
downloadgentoo-a9d766d6acb7ddf76b71a91e157a3b0c48593523.tar.gz
gentoo-a9d766d6acb7ddf76b71a91e157a3b0c48593523.tar.bz2
gentoo-a9d766d6acb7ddf76b71a91e157a3b0c48593523.zip
dev-php/pecl-yaml: Version bumps
PHP 7 support should be in a new slot Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/pecl-yaml/pecl-yaml-1.3.0_beta1.ebuild')
-rw-r--r--dev-php/pecl-yaml/pecl-yaml-1.3.0_beta1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/pecl-yaml/pecl-yaml-1.3.0_beta1.ebuild b/dev-php/pecl-yaml/pecl-yaml-1.3.0_beta1.ebuild
new file mode 100644
index 000000000000..94f5200ff92d
--- /dev/null
+++ b/dev-php/pecl-yaml/pecl-yaml-1.3.0_beta1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PV="${PV/_beta/b}"
+PHP_EXT_PECL_FILENAME="yaml-${MY_PV}.tgz"
+PHP_EXT_NAME="yaml"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS README )
+
+USE_PHP="php5-5 php5-6"
+
+inherit php-ext-pecl-r3
+
+S="${WORKDIR}/yaml-${MY_PV}"
+PHP_EXT_S="${S}"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="YAML 1.1 (YAML Ain't Markup Language) serialization for PHP"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libyaml-0.1.0"
+RDEPEND="${DEPEND}"
+PHP_EXT_ECONF_ARGS=""