summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-20 12:41:04 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-20 12:42:29 -0500
commit6edfb8faeced306ecfa284deeb32f9fa2d5a44b0 (patch)
treeece7b35e6f0310e19ec48aa63ed53c4242c91620 /dev-php/smarty
parentdev-vcs/git-spindle: Updated dependencies (diff)
downloadgentoo-6edfb8faeced306ecfa284deeb32f9fa2d5a44b0.tar.gz
gentoo-6edfb8faeced306ecfa284deeb32f9fa2d5a44b0.tar.bz2
gentoo-6edfb8faeced306ecfa284deeb32f9fa2d5a44b0.zip
dev-php/smarty: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/Manifest1
-rw-r--r--dev-php/smarty/smarty-3.1.31.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index 5a239d16e33e..c0c54cd38d6e 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,2 +1,3 @@
DIST manual-en.3.1.14.zip 408414 SHA256 3aabe51e932b790d24dd8a3c77188b43b99a127f3adaeb0108f085c310404850 SHA512 d384e3856b45ed3f992f3732a5465120abe9fb947cdf13ff67a9c4264f72987d24885ee61cd7309b728e64cdfe4f34c3e7f757096d35de56d962f3b78def9e58 WHIRLPOOL 33dd45ea6cd7bc1129625eb72417fae7c41226a92a6aaddcb72c4426517bd465529599fd8bfc259d8bc3f70f7cd064ada020da4ea7d260cf9801af6944db29f4
DIST smarty-3.1.30.tar.gz 255464 SHA256 62461370c73fb3eb315c6a0a55f9bdbb04d115a0e3eaf46d76d68336524f344f SHA512 6ad9a6cf10b81fecbdc4daa4acbd9724db5f1c2a014e35039b36b0bf00ba000946a2126f7da5899e587a79419f451aafcd1ee14597a32cf290bbd0bf13a877d0 WHIRLPOOL c78d912618f80cbc8226c10b8371ed9514417149cc5f694967616ff3b9c880c424351a303fc14ab42a2dc7683c015c41c7b9006a3123f76df918b75d303463bd
+DIST smarty-3.1.31.tar.gz 244196 SHA256 b1f2976a3fabfd4e91f1412e262bc55118af30f46e2fcde2a8ba69192aae82d3 SHA512 807343e4229413ea0f5219a828d4e91603fb5454f4abe8aa2d41f0a6fe32fa476e791340e1e95178ded3774d1524e98489c104c6fa391e70a8225de28fdcca18 WHIRLPOOL 71cf9eb8d18149538f374939715e921bf04420e2b7ed4ff30a4ac7857ee2807052c7ee2725eaa19bdc63f2aa59fa785ca73cad162b5d2bbaeb35677679a84602
diff --git a/dev-php/smarty/smarty-3.1.31.ebuild b/dev-php/smarty/smarty-3.1.31.ebuild
new file mode 100644
index 000000000000..827b7adbb4ba
--- /dev/null
+++ b/dev-php/smarty/smarty-3.1.31.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DOC_PV="3.1.14"
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( http://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-arch/unzip )"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ local DOCS=( *.txt README README.md )
+ local HTML_DOCS
+ use doc && HTML_DOCS="${WORKDIR}/manual-en/"*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}