summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-05-14 13:40:44 -0400
committerBrian Evans <grknight@gentoo.org>2018-05-14 13:47:22 -0400
commitfc13a49bfc1c37d666d8a18090c34430336ef566 (patch)
treef45d88744aa1b77ef3f2fedcc2e8d13fb557a46e /dev-php/smarty
parentwww-client/chromium: stable channel bump (66.0.3359.170) (diff)
downloadgentoo-fc13a49bfc1c37d666d8a18090c34430336ef566.tar.gz
gentoo-fc13a49bfc1c37d666d8a18090c34430336ef566.tar.bz2
gentoo-fc13a49bfc1c37d666d8a18090c34430336ef566.zip
dev-php/smarty: Version bump to 3.1.32
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/Manifest1
-rw-r--r--dev-php/smarty/smarty-3.1.32.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index 1caaa40d19c4..a9bcfbbc3fe8 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,3 +1,4 @@
DIST manual-en.3.1.14.zip 408414 BLAKE2B 03d4e7a386eb3bd5b19e5c555ec34b86812838a5b5fac8ec0ab9701fba89a5867714da57d950f68224a89bbe2267c18d638ee850681860de309c74bbfb3d0a0b SHA512 d384e3856b45ed3f992f3732a5465120abe9fb947cdf13ff67a9c4264f72987d24885ee61cd7309b728e64cdfe4f34c3e7f757096d35de56d962f3b78def9e58
DIST smarty-3.1.30.tar.gz 255464 BLAKE2B 8378e6336f271e3c41e16b8fbb70356827ff4a9a61e3cf2a23fdbd0617155ec9dca6a5b6372327d4b35a5c6f7c3b58e807afe7403b7ed929ebacfb3c36e124d0 SHA512 6ad9a6cf10b81fecbdc4daa4acbd9724db5f1c2a014e35039b36b0bf00ba000946a2126f7da5899e587a79419f451aafcd1ee14597a32cf290bbd0bf13a877d0
DIST smarty-3.1.31.tar.gz 244196 BLAKE2B 695bd40d337e8f2d4a44a7b30b743ab4e5b6a7b024a514de956cd513dd6639ac6f9ae464f0d3b4cfcaf7de17994837a866cdd4945780bd3a96ff32df300302a3 SHA512 807343e4229413ea0f5219a828d4e91603fb5454f4abe8aa2d41f0a6fe32fa476e791340e1e95178ded3774d1524e98489c104c6fa391e70a8225de28fdcca18
+DIST smarty-3.1.32.tar.gz 250680 BLAKE2B 92d4942f2d3d802b18082f5f6079c8b6945abadd8ef2c87ea217b106eeeedfbde7f1bd00c6fced67b73fc3cf328ec91fc1fb61c7f991b992167fa9d2fb1f2ad2 SHA512 07c95177172718158b9b562c6d8ff79566f4bd8e07ba394cc82c52dec7ec869935fd03ce523115c08472159adf68b902d1db5f8543201a35adf22027c5978080
diff --git a/dev-php/smarty/smarty-3.1.32.ebuild b/dev-php/smarty/smarty-3.1.32.ebuild
new file mode 100644
index 000000000000..d1a7a62bef98
--- /dev/null
+++ b/dev-php/smarty/smarty-3.1.32.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DOC_PV="3.1.14"
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( http://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-arch/unzip )"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ local DOCS=( *.txt README README.md )
+ local HTML_DOCS
+ use doc && HTML_DOCS="${WORKDIR}/manual-en/"*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}