summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2016-11-24 08:33:47 +0100
committerMichael Orlitzky <mjo@gentoo.org>2016-12-18 18:17:01 -0500
commita78020686e96a4d276c3a38fc489e55ccea97dd7 (patch)
treed75dded485c9b7fa7122d590112eda6a6d4fd4c1 /dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild
parentdev-php/jsonlint: Add 1.4.0 version (diff)
downloadgentoo-a78020686e96a4d276c3a38fc489e55ccea97dd7.tar.gz
gentoo-a78020686e96a4d276c3a38fc489e55ccea97dd7.tar.bz2
gentoo-a78020686e96a4d276c3a38fc489e55ccea97dd7.zip
dev-php/spdx-licenses: Add 1.0.0 version
This is needed for composer-1.2.2, bug 439206. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild')
-rw-r--r--dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild b/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild
new file mode 100644
index 000000000000..da59be8de0b4
--- /dev/null
+++ b/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Tools for working with the SPDX license list and validating licenses"
+HOMEPAGE="https://github.com/composer/spdx-licenses"
+SRC_URI="https://github.com/composer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-change-res-path.patch"
+)
+
+src_install() {
+ insinto "/usr/share/php/Composer/Spdx"
+ doins -r src/. res "${FILESDIR}"/autoload.php
+ dodoc README.md
+}