summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-09-07 13:16:32 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-20 14:00:22 +0200
commit426752cf8ef1353151492c8bd76e3b06fd5c6ea5 (patch)
tree274295a463f9db5b69f4aebb3d48c390cda4c552 /dev-php/symfony-console/symfony-console-2.8.43.ebuild
parentdev-php/spdx-licenses: bump to 1.4.0 (diff)
downloadgentoo-426752cf8ef1353151492c8bd76e3b06fd5c6ea5.tar.gz
gentoo-426752cf8ef1353151492c8bd76e3b06fd5c6ea5.tar.bz2
gentoo-426752cf8ef1353151492c8bd76e3b06fd5c6ea5.zip
dev-php/symfony-console: bump to 2.8.43
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-php/symfony-console/symfony-console-2.8.43.ebuild')
-rw-r--r--dev-php/symfony-console/symfony-console-2.8.43.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/symfony-console/symfony-console-2.8.43.ebuild b/dev-php/symfony-console/symfony-console-2.8.43.ebuild
new file mode 100644
index 000000000000..b543b5440226
--- /dev/null
+++ b/dev-php/symfony-console/symfony-console-2.8.43.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Subtree split of the Symfony Console Component"
+HOMEPAGE="https://github.com/symfony/console"
+SRC_URI="https://github.com/symfony/console/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2
+ >=dev-php/symfony-event-dispatcher-2.1.0
+ >=dev-php/symfony-process-2.8.12"
+
+S="${WORKDIR}/console-${PV}"
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Console"
+ doins -r . "${FILESDIR}"/autoload.php
+ dodoc README.md
+}