summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/tcpdf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/tcpdf')
-rw-r--r--dev-php/tcpdf/Manifest2
-rw-r--r--dev-php/tcpdf/metadata.xml8
-rw-r--r--dev-php/tcpdf/tcpdf-5.9.149.ebuild32
-rw-r--r--dev-php/tcpdf/tcpdf-6.0.096.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-php/tcpdf/Manifest b/dev-php/tcpdf/Manifest
new file mode 100644
index 000000000000..16d178bb6ac0
--- /dev/null
+++ b/dev-php/tcpdf/Manifest
@@ -0,0 +1,2 @@
+DIST tcpdf_5_9_149.zip 11636507 SHA256 f08579dff46ef648bd3f076ca679b3932604edbef188cc504f38c243f8e9b362 SHA512 c1821f59a5e46088bca424c047f3cf10bf9b9f68a63b2cd714d449a6cb6e06270285604b08be8fc660b5cd3785c3db00e46fc6a8d8f54e9f3bd86704f5a9aa07 WHIRLPOOL 4a357e5a689ceb2eb143d17957365b76a2ea0363c9003d3c8944e1bfb377f61bb053938235e8b56c62a6a1dffc6021e7c6a142d0dfee6a18d3ac3299bc19d6ed
+DIST tcpdf_6_0_096.zip 16734285 SHA256 352086268b86900b9c6a68353ac5f31a86438d10f20f49797248f3f4b41e605b SHA512 99a554d02ee5e1f5288a09c95aa11c3a1384112a133bf98069a08ec6b02d87459366645b6d0548cc293f71f85f2b9b661644e5151dab50834b6b5d70cc1126a5 WHIRLPOOL 31dc13ca81f927f8be84e425839088af0092b2e96246ce10480897ee3fa32d3d22020e45f29aa7ccf9d7f1ea5fbb480d8261138bb7e3f60e1c07554720435d5d
diff --git a/dev-php/tcpdf/metadata.xml b/dev-php/tcpdf/metadata.xml
new file mode 100644
index 000000000000..04e7563e8098
--- /dev/null
+++ b/dev-php/tcpdf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <upstream>
+ <remote-id type="sourceforge">tcpdf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/tcpdf/tcpdf-5.9.149.ebuild b/dev-php/tcpdf/tcpdf-5.9.149.ebuild
new file mode 100644
index 000000000000..d6bb2df94257
--- /dev/null
+++ b/dev-php/tcpdf/tcpdf-5.9.149.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+KEYWORDS="~amd64 ~x86"
+
+MY_P=${PN}_${PV//./_}
+
+DESCRIPTION="TCPDF is a FLOSS PHP class for generating PDF documents"
+HOMEPAGE="http://www.tcpdf.org/"
+SRC_URI="mirror://sourceforge/tcpdf/${MY_P}.zip"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="dev-lang/php"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins *.php tcpdf.*
+ doins -r config images fonts cache
+
+ dodoc CHANGELOG.TXT README.TXT
+
+ dohtml -r doc/*
+ use examples && dodoc -r examples
+}
diff --git a/dev-php/tcpdf/tcpdf-6.0.096.ebuild b/dev-php/tcpdf/tcpdf-6.0.096.ebuild
new file mode 100644
index 000000000000..79a95f2b48f2
--- /dev/null
+++ b/dev-php/tcpdf/tcpdf-6.0.096.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64 ~x86"
+
+MY_P=${PN}_${PV//./_}
+
+DESCRIPTION="TCPDF is a FLOSS PHP class for generating PDF documents"
+HOMEPAGE="http://www.tcpdf.org/"
+SRC_URI="mirror://sourceforge/tcpdf/${MY_P}.zip"
+# Main source is LGPL-3+, some included fonts have other licenses
+LICENSE="LGPL-3+ GPL-3 BitstreamVera GPL-2"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="dev-lang/php"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins *.php tcpdf.*
+ doins -r config include fonts tools
+
+ dodoc CHANGELOG.TXT README.TXT
+
+ use examples && dodoc -r examples
+}