summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-27 10:06:00 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-27 10:06:35 +0100
commit0918216ec5f9ecf845c0c8f5ef52dc6fe7e4fe75 (patch)
treebc46d509306fdba4a04163e649008e7f9a24651e /dev-php/theseer-tokenizer
parentdev-php/doctrine: bummp to v2.6.4 (diff)
downloadgentoo-0918216ec5f9ecf845c0c8f5ef52dc6fe7e4fe75.tar.gz
gentoo-0918216ec5f9ecf845c0c8f5ef52dc6fe7e4fe75.tar.bz2
gentoo-0918216ec5f9ecf845c0c8f5ef52dc6fe7e4fe75.zip
dev-php/theseer-tokenizer: bump to v1.1.3
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/theseer-tokenizer')
-rw-r--r--dev-php/theseer-tokenizer/Manifest1
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/Manifest b/dev-php/theseer-tokenizer/Manifest
index f9a07ea9687a..e15e922ad4c2 100644
--- a/dev-php/theseer-tokenizer/Manifest
+++ b/dev-php/theseer-tokenizer/Manifest
@@ -1 +1,2 @@
DIST theseer-tokenizer-1.1.0.tar.gz 10163 BLAKE2B b2360f901d60f784db2045912707a8e293a55967d60d4e72168a1c4b0c9a2d5bdb739fbed9bfec02075476e7bf6762eb1cc7e36870b84fcc341b609527579ca2 SHA512 8b500565dc0d6c8513db3aa72a7ee1fa04510a712ce9b0977feccddc6b2dae53825e39182d43508e196f326776115789e81697116418f6f9f63d08f0c05d0543
+DIST theseer-tokenizer-1.1.3.tar.gz 10553 BLAKE2B 4bed1623abe110cec432a97fbd28752618420a188b450c935c77b5771d6986be9a51c8f100fd81a89d892b0c1e2b46b0124e3c35e3cbe2138eee2d520c74933a SHA512 e29fd41b311bac8021f4c0593d79a9c1bde4b6ccf4774e94d27a0e8a97bac3844109f9312c4aab6e239365630394b602b56a084c291dc13fb439dc8ac22944e3
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild
new file mode 100644
index 000000000000..5e52b63d58ae
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.0:*[tokenizer,xmlwriter]"
+
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_prepare() {
+ cp "${FILESDIR}/autoload.php" src/ || die
+ default
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins src/*.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit || die "Unit testing failed!"
+}