summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-02-11 13:56:05 -0500
committerBrian Evans <grknight@gentoo.org>2020-02-11 14:52:38 -0500
commit31667fe13fac41d26d5c93645a75c885c9dc3b3e (patch)
tree877a4681fd020fee70a72eebf0b5778302beba34 /dev-php/xdebug-client/xdebug-client-2.9.2.ebuild
parentnet-print/hplip: ppc64 stable wrt bug #706146 (diff)
downloadgentoo-31667fe13fac41d26d5c93645a75c885c9dc3b3e.tar.gz
gentoo-31667fe13fac41d26d5c93645a75c885c9dc3b3e.tar.bz2
gentoo-31667fe13fac41d26d5c93645a75c885c9dc3b3e.zip
dev-php/xdebug-client: Version bump for 2.9.2
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/xdebug-client/xdebug-client-2.9.2.ebuild')
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.9.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/xdebug-client/xdebug-client-2.9.2.ebuild b/dev-php/xdebug-client/xdebug-client-2.9.2.ebuild
new file mode 100644
index 000000000000..ad1c2866a297
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.9.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+MY_PN="xdebug"
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+inherit autotools
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)"
+HOMEPAGE="https://xdebug.org/"
+# Using tarball from GitHub for tests
+#SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit ) net-libs/libnsl:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with libedit)
+}
+
+src_install() {
+ newbin debugclient xdebug
+}