summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-30 03:28:57 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-03-30 03:28:57 +0200
commit1b4cfca8e341475b9878e7046531ec89e5e1530d (patch)
treebf1024a98665f8099c502dbc4cd2cb8b3ae4a60c /dev-php/xdebug-client/xdebug-client-2.9.4.ebuild
parentx11-plugins/enigmail: bump to v2.1.6 (diff)
downloadgentoo-1b4cfca8e341475b9878e7046531ec89e5e1530d.tar.gz
gentoo-1b4cfca8e341475b9878e7046531ec89e5e1530d.tar.bz2
gentoo-1b4cfca8e341475b9878e7046531ec89e5e1530d.zip
dev-php/xdebug-client: bump to v2.9.4
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/xdebug-client/xdebug-client-2.9.4.ebuild')
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.9.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/xdebug-client/xdebug-client-2.9.4.ebuild b/dev-php/xdebug-client/xdebug-client-2.9.4.ebuild
new file mode 100644
index 000000000000..ad1c2866a297
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.9.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+MY_PN="xdebug"
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+inherit autotools
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)"
+HOMEPAGE="https://xdebug.org/"
+# Using tarball from GitHub for tests
+#SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit ) net-libs/libnsl:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with libedit)
+}
+
+src_install() {
+ newbin debugclient xdebug
+}