summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-10-26 11:51:51 -0400
committerBrian Evans <grknight@gentoo.org>2016-10-26 11:52:57 -0400
commit67458a253a0de746569398514fad63dd1cd3220c (patch)
tree31f558c97e4910f3e2bb39355f52c4097d589a82 /dev-php/xdebug
parentdev-php/xdebug-client: Version bump (diff)
downloadgentoo-67458a253a0de746569398514fad63dd1cd3220c.tar.gz
gentoo-67458a253a0de746569398514fad63dd1cd3220c.tar.bz2
gentoo-67458a253a0de746569398514fad63dd1cd3220c.zip
dev-php/xdebug: Version bump
Convert to EAPI6 Drop support for php 5.5 Move configuration defaults to FILESDIR to speed up building Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/xdebug')
-rw-r--r--dev-php/xdebug/Manifest1
-rw-r--r--dev-php/xdebug/files/2.4.1-xdebug.ini46
-rw-r--r--dev-php/xdebug/xdebug-2.4.1.ebuild40
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-php/xdebug/Manifest b/dev-php/xdebug/Manifest
index 82327a497643..55d502555cb7 100644
--- a/dev-php/xdebug/Manifest
+++ b/dev-php/xdebug/Manifest
@@ -3,3 +3,4 @@ DIST xdebug-2.2.7.tgz 256437 SHA256 4fce7fc794ccbb1dd0b961191cd0323516e216502fe7
DIST xdebug-2.3.1.tgz 266218 SHA256 b50365896089c76d6d64924b66428cc5ef6b4802371e3d422581b3c34d3ca64c SHA512 aca3ce1546f8b99482f55c0f09e532addecff7db4cc81818260b2d3524fd6888e05c15ed0f98f25a139c40e011540705f02aab56f4c52d90212a843459493bd2 WHIRLPOOL 69e4545c1489f240a23ba4ee70afec754471e5cbffdd48a1d5f5db1eace13982807b1e30ae2efd541f79b658613e770ad2dea1ca016a67037e5b5b59ce08fb9c
DIST xdebug-2.3.3.tgz 268381 SHA256 b27bd09b23136d242dbc94f4503c98f012a521d5597002c9d463a63c6b0cdfe3 SHA512 212604e87caa67b3734befa0f57580532b0edd346ed871bbaba72ba8319ba60eb8d66649cb5716df250f28ef1cd2384ccc6f651b90ab4936dbcb45ef6c5f7438 WHIRLPOOL f228a2527dc9f2a166bdd4f2920537d5bc66e00f528f21ca05b7038ca535fb3011f3f39a39871c5ac0a62d46d3c3f3eb4a76d33e9c33c79b633be252e89af23e
DIST xdebug-2.4.0.tgz 264832 SHA256 3c4dcb2709d1653534e7cfaa546307041afd298ac48a3670183a12cfdb5eee05 SHA512 3cc4b5d0cec8048543a9b34a61479303b15fe765d24507a2d24ac42f2f18c625cccc3c44b2e4dacb923f05dd429df8ca3a8909a9def9920d3f44514a31f7cf29 WHIRLPOOL c03876cb1124705b2423ea6d9e54ef3f1555898f1f2f8d94f62b6c91ced971683b31426eea220dacdd49fb983cadac8563d41bf118984ce56cbf11cd620d2931
+DIST xdebug-2.4.1.tgz 265542 SHA256 23c8786e0f5aae67b1e5035972bfff282710fb84c483887cebceb8ef5bbdf8ef SHA512 64b345b4809fb0f020eb8fe7a0826056a64728ec9565bbb2d0e717ac7b3ca8aa0856b91c2ba47a7435b7500c5efa643682f245d6cd9d0a537f8bb9ab0d5cea3a WHIRLPOOL cad7d081414d5a55fb95e4cb6ae5d808f5c6b54e1c16ba78274fadf9b32dd10e60ecab3d09d420462b7c95f7d9364d9f886fe7732a21284c635e70c24259a610
diff --git a/dev-php/xdebug/files/2.4.1-xdebug.ini b/dev-php/xdebug/files/2.4.1-xdebug.ini
new file mode 100644
index 000000000000..62042aee217b
--- /dev/null
+++ b/dev-php/xdebug/files/2.4.1-xdebug.ini
@@ -0,0 +1,46 @@
+xdebug.auto_trace="0"
+xdebug.trace_output_dir="/tmp"
+xdebug.trace_output_name="trace.%c"
+xdebug.trace_format="0"
+xdebug.trace_options="0"
+xdebug.collect_includes="1"
+xdebug.collect_params="0"
+xdebug.collect_return="0"
+xdebug.collect_vars="0"
+xdebug.default_enable="1"
+xdebug.extended_info="1"
+xdebug.manual_url="http://www.php.net"
+xdebug.max_nesting_level="256"
+xdebug.show_error_trace="0"
+xdebug.show_exception_trace="0"
+xdebug.show_local_vars="0"
+xdebug.show_mem_delta="0"
+xdebug.dump.COOKIE="NULL"
+xdebug.dump.ENV="NULL"
+xdebug.dump.FILES="NULL"
+xdebug.dump.GET="NULL"
+xdebug.dump.POST="NULL"
+xdebug.dump.REQUEST="NULL"
+xdebug.dump.SERVER="NULL"
+xdebug.dump.SESSION="NULL"
+xdebug.dump_globals="1"
+xdebug.dump_once="1"
+xdebug.dump_undefined="0"
+xdebug.overload_var_dump="2"
+xdebug.profiler_enable="0"
+xdebug.profiler_output_dir="/tmp"
+xdebug.profiler_output_name="cachegrind.out.%p"
+xdebug.profiler_enable_trigger="0"
+xdebug.profiler_append="0"
+xdebug.profiler_aggregate="0"
+xdebug.remote_enable="0"
+xdebug.remote_handler="dbgp"
+xdebug.remote_host="localhost"
+xdebug.remote_mode="req"
+xdebug.remote_port="9000"
+xdebug.remote_autostart="0"
+xdebug.remote_log=""
+xdebug.idekey=""
+xdebug.var_display_max_data="512"
+xdebug.var_display_max_depth="2"
+xdebug.var_display_max_children="128"
diff --git a/dev-php/xdebug/xdebug-2.4.1.ebuild b/dev-php/xdebug/xdebug-2.4.1.ebuild
new file mode 100644
index 000000000000..937ace6a33f6
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_INIFILE="2.4.1-xdebug.ini"
+
+USE_PHP="php7-0 php5-6"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+DOCS=( README.rst CREDITS )
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}